Network and Storage Protocols

Root user cannot access directories created by other users on NFS share?


Hey folks,

I'm trying to use a Storevault S500 as a storage location for Zmanda's ZRM for MySQL backups.  I have exported a directory in /vol/exports as an nfs share, and have mounted the share on my backup server (running Ubuntu).  Both the 'mysql' user and the 'root' user must access this share at times during the backup process.  The 'mysql' user creates a new directory for a backup, but then runs a command in that directory with sudo.  The command fails because, for some reason, the 'root' user does not have access to the directory 'mysql' created!  I tried the options for security in the Manage Exports dialogue to attempt to give all users from that host access as 'root', but that did not help matters.  Can anyone offer advice?  Where am I going wrong?





Can you post your /vol/vol0/etc/exports file?

It would be really useful to diagnose the issue.

-- Adam Fox


Sure can, thanks for replying.  It's been a while since I've used the CLI...  can you refresh my memory on how best to get a copy for you?  I'll post as soon as I can figure it out.




Ah, found it.

nas01*> rdfile /vol/vol0/etc/exports
#Auto-generated by setup Sun Mar 14 01:04:16 GMT 2010
/vol/vol0       -sec=sys,rw,anon=0,nosuid
/vol/vol0/home  -sec=sys,rw,nosuid
/vol/shares     -sec=sys,rw,nosuid
/vol/exports    -sec=sys,rw,nosuid
/vol/exports/replica/DB_Backups -sec=sys,rw,root=zrm_server.MYDOMAIN.local:db1.MYDOMAIN.local:db2.MYDOMAIN.local:db1:db2:zrm_server:,anon=0


That looks fine.  Though maybe try busting that down to a single IP address for the root mount?

# rdfile /etc/exports
/vol/xen_office_1       -sec=sys,rw,root=
/vol/vol0       -sec=sys,rw=
/vol/bnesbitt_test5     -sec=sys,rw,root=,nosuid


Ok, which export is having the issue?


Thanks for the replies! I eventually had to completely restore the

Storevault to fix an unrelated issue. When I tried again the second

time I just modified the default export the same way I had been trying

to share the single folder before and had no problems.

Thanks, and have an interesting day!

Mike Naglee

Prestige Magazine

EASyads IT Dept.