Network and Storage Protocols

Unable to maintain NTFS permissions when copy from Windows server to NetApp

dmandell
10,226 Views

I must be missing something

really basic here.

I am trying to migrate files and folders from a Windows server to a NetApp.

I have tried xcopy, robocopy, but am unable to have the permissions follow once the files are copied.

The location is a mixed mode qtree.

The procedure I did was to mount the filer share from the windows server and attempt to copy the files.

The files copy without issue, but the permissions are reset to "everybody" (I am not concerned that the owner changes.)

If I change the permissions of the shared folder before copy, all of those permissions are inherited.

How can I get the existing file permissions to follow the files when they are copied?

Thanks,

Dana

15 REPLIES 15

neto
10,155 Views

Hi Dana

This is neto from Brazil

How are you?

Is there any reason that you are using mixed qtree and not ntfs style?

Robocopy is a good tool for migration including NTFS ACL's.

How are the options that you chose using robocopy?

All the best

neto

dmandell
10,156 Views

Neto,

Thanks for the quick reply.

I just got it to work.

I was under the impression that /mir did not need /copyall to get the permissions to carry over.

Including /copyall did the trick.

Thanks,

Dana

P.S. the mixed qtree was so that Linux users could still connect to their home folders and change file permissions.

neto
10,156 Views

Perfect

NetApp - I love this company!

amiller_1
10,156 Views

And....if you'd like another option, check out RichCopy (GUI-driven + multi-threaded....not necessarily better than Robocopy but another option).

dmandell
10,156 Views

Thanks, Andrew.

I will check it out.

The multithreaded part looks to me most useful!

-Dana

__COLIN_GRAHAM_14270
10,157 Views

Richcopy is good, but its buggy and as far as i know (unless its been updated in the last 2 months) cannot copy ACLs correctly.

as said above, on my migrations i used robocopy with the /copyall flag and also /ZB to deal with dodgy-permissions/locked files

If your migrating alot of data, consider using a Win2k8 box, as this version of robocopy is much newer and is multi-threaded.

dmandell
10,157 Views

Yes, copying ACLs is most important in this case.

Does anyone know if one can use the Win2k8 version of robocopy with win2k3? (R1 or R2)

__COLIN_GRAHAM_14270
10,157 Views

No.. unfortunately its 2k8 only i think this same version is also bundled with vista SP1 if thats any use?

also check out the wikipedia page for robocopy, its got some handy info about versions, bugs and limitations.

I ended up using the original XP10 version as XP26 had a major bug (i cant remember what it was off the top of my head.. it was either not replicating timestamps correctly, or a ACL issue)

pash_hrnic
10,155 Views

I'm running into a very similar problem...except in my case I have assigned the qtree security type to NTFS.  When I richcopy the files over (with appropriate options to copy security info) the permissions are not copied.  Just for kicks, I ran the same copy tool against a qtree with mixed security and it copied the NTFS permissions just fine...

I really want to use NTFS only.

dmandell
6,779 Views

Do you have the same issue when using RoboCopy instead of RichCopy?

I have read elsewhere online of others with ACL (permission) problems as well with RichCopy, but not RoboCopy.

pash_hrnic
6,779 Views

It's worth a shot.  I'll try robocopy and let you know.

Thanks.

pash_hrnic
6,779 Views

Used robocopy, same result.  NTFS perms not being copied over.  Everyone group has FULL access to everything I copy over...

Keep in mind richcopy copied the NTFS perms over just fine when I copied  to a mixed security qtree...

Any ideas?

dmandell
6,779 Views

What permissions do the files have after copy?

Did you use /copyall option with robocopy?

pash_hrnic
6,779 Views

Wonderful.  That's what I was looking for!

Thanks.

__COLIN_GRAHAM_14270
6,778 Views

Just for info, ive attached a userguide for Robocopy, bear in mind its for the XP10 version but all the major switches and options should apply to newer versions..

Always remember /mir /copyall is the surefire way to mirror with permissions.

happy migrating

Public