Network and Storage Protocols

Unable to readd vfiler into domain with same name.

SATYAIRRINKI1
4,936 Views

hostname of Vfiler has been removed from windows AD and readded.

Trying to readd Vfiler into domain with same hostname for CIFS access.

>vfiler run <filer name > cifs terminate --throws error

CIFS: CIFS did not shut down: CIFS terminate aborted because client sessions did not disconnect properly.

>vfiler run <filer name > cifs sessions ---shows nothing.

Request you to assist on the same ..

13 REPLIES 13

sharmadevender
4,933 Views

You must first terminate cifs services and then try to delete AD account of filer.

Now you can try to failover {using halt -f or -d command to clear it}

And then rejoin to domain.

SATYAIRRINKI1
4,933 Views

Not able to terminate session please find log for the same ..

>vfiler run <filer name> cifs terminate

Total number of connected CIFS users: 1

     Total number of open CIFS files: 3

Warning: Terminating CIFS service while files are open may cause data loss!!

Enter the number of minutes to wait before disconnecting [5]: 1

...

waiting 5 seconds more
waiting 3 seconds more
waiting 1 seconds more
CIFS termination of vfiler <filer name>has been aborted because
a CIFS session could not be disconnected properly. If this
problem persists, please obtain a core dump by running the
``halt -d <explanation>'' command, and report the incident
to Network Appliance Global Services.

CIFS Terminate failed.

>vfiler run <filer name> cifs sessions

Root volume language is not set. Use vol lang.

Will search for DC on next connection

====================================================

PC IP(PC Name) (user)           #shares   #files

There is no fail over configured for it ..halt -d/-f whill it shutdown filer or vfiler ?

martin_fisher
4,933 Views

Hi - have you tried a CIFS restart on the vFiler to restart and the service or a CIFS setup. You can delete the AD Account for the vFiler, without shutting down CIFS.

If CIFS fails to terminate, then you may need to restart the vFiler first, then try again.

sharmadevender
4,933 Views

yes halt -d will shutdown the filer creating dump. What's the Data ontap version, because we can see bug related to cifs termination in few Ontap and halt -d is only solution.

SATYAIRRINKI1
4,933 Views

Ontap 7.3.1.1,We cant shutdown the Filer which will effect other cifs shares hosted on Filer.Can't we forcely terminate cifs sessions for vfiler and readd to domain.

ASHWANI8HIGHS
4,933 Views

If cifs service is up then cifs restart will wont work .Instead try connecting vfiler using windows host (with admin login)  close all three opened files which are in write + read mode Then try cifs terminate .

martin_fisher
4,933 Views

Connect to the vFiler using the Windows MMC and manage the host. You should the be able to see any open files of folders. If not restart the vFiler (not the host filer).

ASHWANI8HIGHS
4,933 Views

I think we missed something    if the vfiler has been removed from AD we cannot connect it to using Windows MMC . I think you have to  re - run the Cifs setup  add the vfiler to domain ,close your open files connecting  vfiler from Windows MMC ,cifs terminate ,exclude the vfiler from domain  .

martin_fisher
4,933 Views

But if you cant terminate CIFS to start with how are you going to re-run the setup?

vFiler needs a restart.

ASHWANI8HIGHS
3,569 Views

I agree with Martin  .. you need to restart the vfiler

SATYAIRRINKI1
3,569 Views

Thanks for your support and quick reverts.

The only option worked out for me is to reboot the filer and re-add vfiler to domain using 'vfiler run <filername> cifs setup'.

I am thinking of other option, other than rebooting the filer?...may be not available ..

SATYAIRRINKI1
3,569 Views

Is this command useful -"lock break -p cifs"

sharmadevender
3,569 Views

In your case, when you run CIFS session, no active sessions were there. So lock command will add no help.

Public