Network and Storage Protocols

VScan Server Status: disconnected

srsilviu
977 Views

Hello,

I have a problem with vscan on one of the SVMs. In logs I find:

12/20/2021 14:28:12 n01 EMERGENCY Nblade.vscanNoScannerConn: Vserver "SVM1" has no virus scanner connection.
12/20/2021 14:28:12 n01 DEBUG ems.engine.suppressed: Event 'Nblade.vscanNoScannerConn' suppressed 8431 times in last 601 seconds.

defthwnac001::*> vscan connection-status show-not-connected -vserver SVM1
(vserver vscan connection-status show-not-connected)
Connection Disconnect
Vserver Node Server Status Reason
------------- ----------------- ---------------- ------------- ---------------
SVM1 n01 10.158.133.7 disconnected -
SVM1 n01 172.16.28.194 disconnected invalid-user
SVM1 n01 10.158.133.7 disconnected -
SVM1 n01 172.16.28.194 disconnected -

defthwnac001::> vscan connection-status show -vserver SVM1
(vserver vscan connection-status show)
Connected Connected
Vserver Node Server-Count Servers
--------------- ------------------- ------------ -----------------------------
SVM1 n01 0 -
SVM1 n02 0 -

defthwnac001::*> vscan scanner-pool privileged-users show -vserver SVM1
(vserver vscan scanner-pool privileged-users show)
Vserver Scanner Pool Privileged Users
--------------- ----------------- --------------------------------------------
SVM1 sp-SVM1 BLG.LOCAL\w9a04229, BLG\w9a04229

The user is correct but it is no serviceaccount user. I don't know what else can I do?

1 ACCEPTED SOLUTION

Ontapforrum
937 Views

Was the LIF migrated or connection drop temp ?

 

What's the output of this:
::> security login show -vserver SVM1

 

Some pointers:
https://docs.netapp.com/ontap-9/index.jsp?topic=%2Fcom.netapp.doc.dot-cm-acg%2FGUID-1F6E33DF-AE5A-4237-90FE-3FE6CD2F8F90.html

 

Make sure that the Vscan server is reachable through at least one LIF on a node so that it can process scan requests for file operations performed on that node.

View solution in original post

5 REPLIES 5

Ontapforrum
975 Views

Please check this kb.

Node1 EMERGENCY Nblade.vscanNoScannerConn: Vserver "SVM1" has no virus scanner connection:
https://kb.netapp.com/Advice_and_Troubleshooting/Data_Storage_Software/ONTAP_OS/Error_%22Vserver_has_no_virus_connection%22_randomly_seen_in_roughly_1...

srsilviu
965 Views

Hi. I have version: NetApp Release 9.7P4 and I couldn't find those kind of logs mentioned, so it must be something else...

Ontapforrum
938 Views

Was the LIF migrated or connection drop temp ?

 

What's the output of this:
::> security login show -vserver SVM1

 

Some pointers:
https://docs.netapp.com/ontap-9/index.jsp?topic=%2Fcom.netapp.doc.dot-cm-acg%2FGUID-1F6E33DF-AE5A-4237-90FE-3FE6CD2F8F90.html

 

Make sure that the Vscan server is reachable through at least one LIF on a node so that it can process scan requests for file operations performed on that node.

srsilviu
837 Views

Hi,

Mandatory scan is off, and I do have network connection to both vscan servers from both nodes. LIF is on home node, not migrated recently...

 

defthwnac001::> security login show -vserver SVM1

Vserver: SVM1
Second
User/Group Authentication Acct Authentication
Name Application Method Role Name Locked Method
-------------- ----------- ------------- ---------------- ------ --------------
BLG\s_ARM_serv ontapi domain 8manrole - none
aip-avuser ontapi password vsadmin no none
vsadmin http password vsadmin yes none
vsadmin ontapi password vsadmin yes none
vsadmin ssh password vsadmin yes none

defthwnac001::> network ping -vserver SVM1 -node n01 -destination 10.158.133.7
10.158.133.7 is alive

defthwnac001::> network ping -vserver SVM1 -node n01 -destination 172.16.28.194
172.16.28.194 is alive

defthwnac001::> network ping -vserver SVM1 -node n02 -destination 10.158.133.7
10.158.133.7 is alive

defthwnac001::> network ping -vserver SVM1 -node n02 -destination 172.16.28.194
172.16.28.194 is alive

srsilviu
881 Views

So I have added the vscan user to vsadmin role and now it works. Thank you!

 

defthwnac001::> security login show -vserver SVM1

Vserver: SVM1
Second
User/Group Authentication Acct Authentication
Name Application Method Role Name Locked Method
-------------- ----------- ------------- ---------------- ------ --------------
BLG\s_ARM_serv ontapi domain 8manrole - none
BLG\w9a04229 ontapi domain vsadmin - none
aip-avuser ontapi password vsadmin no none
vsadmin http password vsadmin yes none
vsadmin ontapi password vsadmin yes none
vsadmin ssh password vsadmin yes none

Public