Network and Storage Protocols

access denied when map a CIFS share


the question maybe a basic one, but could not figure it out myself. Please see the following

"share1" is the share I created, and everyone has the full access. The filer has been setup in a domain controller. from window site,  I don't have the problem to access "netapp" share, but why I can not access "share1"? Please help  me out.

nas1> cifs shares

Name         Mount Point                       Description

----         -----------                       -----------

ETC$         /etc                              Remote Administration

                        BUILTIN\Administrators / Full Control

C$           /                                 Remote Administration

                        BUILTIN\Administrators / Full Control

                        root / Full Control

netapp       /vol/test1/home

                        everyone / Full Control

share1       /vol/testvol_dest

                        everyone / Full Control



Can you please share the error what you are getting and the out put of     nas1> vol status testvol_dest  &  nas1 > vol options testvol_dest 


  the following error on my laptop where I am trying to map the share, it's kind of missleading. the first, it shows me access denied, then it shows me the following message, after I tried more than one times:

nas1> vol status testvol_dest

         Volume State           Status            Options

   testvol_dest online          raid_dp, flex     nosnap=on, snapmirrored=on,

                                snapmirrored      create_ucode=on,

                                read-only         maxdirsize=31457,


                Containing aggregate: 'aggr1'

nas1> vol options testvol_dest

nosnap=on, nosnapdir=off, minra=off, no_atime_update=off, nvfail=off,

ignore_inconsistent=off, snapmirrored=on, create_ucode=on,

convert_ucode=off, maxdirsize=31457, schedsnapname=ordinal,

fs_size_fixed=on, compression=off, guarantee=volume, svo_enable=off,

svo_checksum=off, svo_allow_rman=off, svo_reject_errors=off,

no_i2p=off, fractional_reserve=100, extent=off, try_first=volume_grow,

read_realloc=off, snapshot_clone_dependency=off


Well netappmagic,

You may wish double check your access right.

Good luck



please let me know where and how can I check "access right"?


Hi netappmagic ,

I am curious to know from the vol status output  that why you need to create a share on read only volume (snapmirrored )  ?

Might be this is reason you are not able to access the share     correct me if  i  am wrong  .I never tried making share on snapmirror dest volume



After I create a brand new volume. It works now. You are absolutely right, I should not use that volume. Thanks a lot!

now, I have a follow-up question.

I can log into the share by using the ID and password on the NAS storage. What should I do to use one of DC ID's to log into it? since this NAS has already been included in the DC domain, If I use a DC id, I am getting the same error window as shown in my early message. This share has FULL CONTROL to EVERYONE.


Hi netappmagic ,

I am not getting what do you mean by log into the share ?  Can you explain it better     or if you have screenshot for the share login . 




cifsshare    /vol/cifstest

                        everyone / Full Control


Hi netappmagic ,

1) Qtree =quota tree  . Its a logical partition inside the volume used to provide quota management . Used in IPSAN enviornment to hold the lun  . A volume can have multiple qtree's to hold multiple lun  .Also used in NAS enviornment to provide storage to multiple shares .

Structure -  /vol/volumename/qtree

2) Share is created in NAS enviornment for accessing the share resources to whom having appropriate rights

hope this can explain