Network and Storage Protocols

cifs setup terminates suddenly without any message.

renton
2,184 Views

Hi All,

 

I have been running cifs setup in a vFiler on a 6280 running 8.2.3P2 7-mode and it terminates unexpectedly and without message after selecting either option for "Multiprotocol" or "NTFS-only" as show below:

 

filer> vfiler run vfilername cifs setup

...

...

...

(1) Multiprotocol filer
(2) NTFS-only filer

Selection (1-2)? [1]: 1
        CIFS requires local /etc/passwd and /etc/group files and default files
        will be created.  The default passwd file contains entries for 'root',
        'pcuser', and 'nobody'.

filer>

 

I manually created /etc/passwd and /etc/group files and then retried the cifs setup. I've never had to do that before. Does anyone know why?

 

Cheers, Renton.

1 ACCEPTED SOLUTION

hariprak
2,093 Views

Hi,

 

This is because CIFS is not configured while configuring vfiler and configured later, then /etc/passwd is not created on the root of the vfiler volume.
You can either setup CIFS while creating vfiler or need to manually create /etc/passwd in root volume of the vfiler

 

 

Thanks

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

View solution in original post

2 REPLIES 2

RPHELANIN
2,172 Views

can you change the root password? if so change it and rerun cifs setup

hariprak
2,094 Views

Hi,

 

This is because CIFS is not configured while configuring vfiler and configured later, then /etc/passwd is not created on the root of the vfiler volume.
You can either setup CIFS while creating vfiler or need to manually create /etc/passwd in root volume of the vfiler

 

 

Thanks

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Public