Network and Storage Protocols

netapp ssh with private/public keys


NOTE that I am still learning so I might have overlooked obvious things.

NOTE that the root volume is not vol0.

NOTE that the management station is a windows host located in the same subnet as the management interfaces for the storage.

Procedure in the management guide says that I need to copy the public key to /etc/sshd/user/authorized_keys.

I tried doing this in several ways however it is not working for me.

What I tried:

1. using ftp

enabled ftp using options ftpd.access.enable on

Tried logging in with the root credentials: fail. I get an error that the password is invalid (I am sure it is correct).

To make sure I added an extra account to connect through ftp: useradmin user add test -g Administrators

Still the same result.

Also I changed the root directory where ftp starts.

Another thing I tried is using the anonymous account.

I enabled it.

Still can't access.

I also tried with restarting ftpd between changes.

Am I missing something here?

2. using cifs

Tried connecting from a windows machine in the same subnet.

Using \\storagenode\c$

I get a message that I can't connect.

It might be because I don't have a license for cifs

3. using nfs

I have an nfs license.

I installed the Windows nfs tools.

I can mount the root volume.

I used"

mount -o user \\storage_node\vol\root_vol x:

I also tried without the user argument.

Both  result in a successful mount.

I can browse the root volume.

Now I want to create a directory in /etc/sshd/ for the user.

I get permission denied in both with and without user argument.

I tried mounting with \vol\root_vol\home. THis goes successfully and I can actually write to this directory.

Once I am back on the console I use:

set priv advanced

THen I try the mv command to /etc/sshd/ (I am aware that I need to create a subdirectory)

Access denied

Also I tried finding a command to create a directory: does not exist.

As I am mounting from a windows host I thought I might need a usermap.cfg file.

So I created this:

* => root

*\root => root

Do I need any further actions to enable this?

I still don't have access and I am out of ideas.

Note that the /etc/exports file uses sys as one of the options.

Thanks in advance for any help! I hope I get this solved.



First of all I must say I'm astonished not a single thing has been answered here.

I believed that this forum was more useful.

Point 2 is clear to me know. Although nobody did confirm it, not being able to connect to the administrative C$ share is because I don't have a license for CIFS.

Which in some way I understand. However it's strange that the manual assumes you have either an NFS or CIFS license.

Nowhere in the documentation it's clear that without this license you can't do this(it's like Netapp forces you to buy a protocol license, otherwhise you can't manage your filer).

As for point 3: I believe this to be an issue with mappings.

It should work. Administrator should automatically map to root user IIRC.

In the end I got this resolved by mounting the volume through NFS(on this filer we have an NFS license).

I'll keep this thread for what it is.