ONTAP Hardware

FAS 2240 reset w/o saving data & general Netapp terminology




This thread should be easy for people, who have been working with netapp for some time. For me, however, this stuff is very new and frustrating.
Ok, here is the deal.

We got a Netapp FAS 2240-2 system. The guys, who worked with this device previously, just removed it from their environment, without any resetting or anything. Now the hardware is mounted into our rack and I`m trying to get the software to do the right thing, but got lost in terminology, Netapp documentation, cables and CLI commands..

So Can anyone please help me regarding this?

Can you please point out, where I could find explanation about terminology Netapp uses? There are nodes, storage-processors, controller-modules, wrench ports, clusters, ONTAP , 7-MODE, etc, etc. I have worked with EMC previously and it seems that they are naming stuff a little bit differently.

Now, moving to a little bit more technical stuff. How do I need to install the wiring on this beast? I have connected the power, SAS connections between nodes (hope I`m using the right name here), ACP cables between nodes. Then on one node I have connected management port to the management switch, data ports to data switch. Do I need to do this with the other node aswell? In the setup guide, there are management and data connections to the switch only from one node.. This got me a bit confused.

Now, after the cabling is done, I connected to the device through serial port, got into bootmentu, resetted both nodes and did initial config on both nodes through terminal. After this I ran system setup from my win laptop. It discovered both nodes and showed them in the list , but setup gave me an error, which stated "too few cluster ports configured" on both nodes. What to do with this error?maybe my cabling is wrong? Or have I made mistakes when resetting or initial configing?

Please help me with these questions, as the HW has been lying in idle mode for too long.. And huge thanks in advance for the answers. I thinked about posting all these three questions seperately, but then again, they are from the same kind and case.. 


It is technically possible to use 1GbE ports for cluster interconnect, but this is not supported configuration and you should understand that it limits total throughout that can be achieved. As this is not supported, it is not offered by setup tool also. For testing purposes you can build such cluster using CLI.

View solution in original post





For SAS and ACP Cabling on FAS 2240 refer,


You can find configuration examples for FAS2240 Systems


Community discussion related to FAS 2240 -2 Startup and Interfaces config,





If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.


Thanks for the reply.


Now the setup utility has discovered both nodes. The bad thing is, that it is still giving me the same error: "The node has fever than 2 cluster node ports configured. System Setup is not able to continiue, because the required ports are not available."

Does anybody have seen this error and maybe has some ideas how to fix it?


Huge appreciation inbound.

Hi Can you please share the output of ifconfig -a and also make sure that ssh is configure or now?


Hi, thanks for chipping in. From where do you want me to run ifconfig? From that bootloader or actual ONTAP OS?


Actually I dont understand, why it is asking me for cluster configuration right after the management interface setup..


That command runs from the ONTAP cli. If you are booting up in cluster mode, it will be "network interface show" and "network port show".  Cluster setup needs to complete before it can serve data, and before most of the other config can take place.  

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.


Okay, this may again be a strange question. You say "Cluster Mode". Are there other modes? Is this the right place to mention 7-mode?
I have only one dual node piece of hardware and there are no plans on acquiring an additional one. Is running this HW in cluster mode even neccesary? 
And can I run that Cluster Setup from That Netapp System Setup utility for Win or do I need to do this from CLI? Some differences between choices?


From your output i came to know that, you are running on Cluster mode data ontap operating system. There are two modes in NetApp data ontap OS 1. 7 mode 2. cluster mode. Both of them have their own features.


I will go trough these steps you provided and try to configure that cluster and post about the results. Can you please tell me how to switch between those modes (7 mode and ONTAP)?

You no need to do that bcz u are already running on cluster mode and that is the advanced data ontap OS. NetApp is going to stop 7-mode support soon. Don't worry about 7-mode.


Hi If it is cluster ontap then first you have to login to first node of the cluster and run "cluster setup". This command runs like a wizard and will ask you for next steps. Please share me your mail id, so that i can share a doc with you which contains step by step cluster configuration.


If you run cluster setup from the CLI, you can't also run the System Setup gui.  The remaining config would need to be done at the CLI or in the system manager GUI.  System Setup can get it up and serving data if you can overcome whatever error conditions it is detecting.  Its likely cabling/connectivity related.  Check that e1a on node A connects to e1a on node B, and e1b on node A connects to e1b on node B.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.


Okay, this wiring thing is getting a bit strange. In the Installation and Setup Instructions for FAS2220/FAS2240-2 System the only wires that interconnect both nodes are SAS 0a, 0b and "wrench" ports. Connections from e0a to e0d (data transfer ports) go only from one node to the data network switch (other node has no data connections to the data switch, which is also strange for me).  What I am not understanding here. I have looked in that instructions guide and universal SAS and ACP cabling guide, then configuration examples. Followed those documents and no such connections were described there.


Hi, Attached the network interface show and network port show outputs from both controllers. Will this do?

Hi You can not connect e0a and e0b to the data network. Please follow the below instructions. Connect your FAS01:e0a to FAS02:e0a FAS01:e0b to FAS02:e0b If you connect them in the above format, they will generate some ip's them self and assign those ip's to all the four ports. We have to use e0a and e0b ports for Intra-cluster connectivity. We can not use them for data network. Please use the remaining ports for data network. After connectivity Login to one of the node and run "cluster setup" command then follow the wizard. Please feel free to reach me if you have any concerns..... 🙂


The cluster network ports e1a and e1b are not present in the output of network port show.  This means the mezzanine slot is either blank, or populated with an FC card.  In either case you will not be able to use a supported cabling topology without first installing a 10GB mezzanine card in each controller.  See page 6 of this document https://library.netapp.com/ecm/ecm_get_file/ECMP1139842  


While its technically possible to use the 1gb ports for the cluster network, you would not be able to use system setup to do so.  The error from system setup is because the ports it needs are not present in your hardware configuration.




If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Sorry, i have not seen the port speed. U need to use 10GB ports for intra cluster network. It is not compulsory to use e1a and e1b.


The supported cluster network port assignments vary by hardware model. In this case, a FAS2240, all of the onboard ports are 1GBE, and the only expansion slot is the mezzanine, so e1a/e1b are the only supported ports.  You can find the supported cluster ports for any given platform in the hardware universe.


If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.


Indeed, I have FC card sticked in those ports. Interconnected them on both controllers and the setup utility accepted the configuration and now I`m waiting for the license to arrive.



So to sum up. FAS 2240-2 system. 2 Controllers.  8Gb FC cards in expansion slots. Wrench port and both expansion ports are interconnected. Both controllers connect to the management network through management ports. And the 4 data ports are going to the data network. I rebooted both nodes, pressed ctrl+c before ONTAP boot but after boot. Then option 4 to wipe all disks and reset the configuration. After reset, booted both nodes up, exit at the initial congiguration. Then ran the Windows setup utility. For now everything seems to work. Maybe this is not the fastest way, but still. Will see about the results.

Please post us the results. I have done this once in my life. That time i am very much exited. You like netapp products very much after you started playing with them. .... Welcome to netapp world 🙂