ONTAP Hardware

rebuild the root volume



We have a question about how to rebuild the root volume.

We have a FAS 2020 filer with 2 controlers, it works on DATA ONTAP, there are 28 *300G  FC disks in 2 FC disk shelves and 12* 1T SATA disks in main box, right now there are 2 aggregates(agg0 is a 14 FC disks agg and agg1 is a 6 SATA disks agg)  in each controlers, and all root vol is on agg0 the FC disk agg.

Right now we want re-build the aggregates like this: assign all 28 FC disks in 1 agg on controler 1 and assign all 12 SATA disks in 1 agg on controler 2. this setting will offer more space and little bit logically than before.

We don't need care the data because there is no data at all on this filer, so our question is can we access this target and how?

Any help will be very appreciate.





You can assign the disks as:

Storage System 1 (FC disks)

Data + Parity Disks = 27

Spare Disks = 1

Create an Aggregate with two RAID groups with raid size = 16

rg1 = 16

rg2 = 11

total usable aggr space = 5498 GB


Storage System 2 (SATA disks)

Data + Parity Disks = 11

Spare Disks = 1

Create an Aggregate with two RAID groups with raid size = 11

rg1 = 11

total usable aggr space = 8188 GB



Copy that, but would recommend to create even reaidgroups as:

rg1 = 13

rg2 = 13

leaves 2 Spare Disks...

just my 2 cents,



Hi Peter,

Because I can’t replay the message from the website, it always show me “An error occurred while trying to submit your post. Please try again.

So I put my replay by mail,

Hi Thank you for your replay, but this is not point.</p>

right now the root vol is in the FC disks agg0 on both controllers. If I need upgrade the ownership of the FC disks on controller B to controller A I must lost the root vol on controller B

how can delete the agg0 which is contain a root vol. then rebuild a new agg0 with SATA disks and create a new root vol on the new agg0

Thank you for your replay!


You can assign all sata disks to one controller

Create new vol0_new on SATA disks

migrate root volume vol0 to vol0_new (on SATA) - migrating root volume requires reboot.

destroy old root vol on FC disks, unassign FC disks on this system and assign to the partner node

change aggr options to raid size (whatever you decide 16 or 13)


Hi nitish,

Still can’t replay on website.

thank you for you replay:

I did these steps:

create a new vol which name is root on a SATA agg aggr1 on same controller.

filer>options ndmpd.enable

Copy the contents of vol0 to root:

filer>ndmpcopy /vol/vol0 /vol/root

looks everything was copied to new vol

Ndmpcoy: Transfer successful 1 min 10 seconds

Ndmcpoy: Done

Make the "root" volume the root volume

filer>vol options root root


Filesystem kbytes used avail capacity Mounted on

/vol/vol0/ 9961472 1385332 8576140 14% /vol/vol0/

/vol/vol0/.snapshot 524288 563380 0 07% /vol/vol/.snapshot

/vol/root/ 11744052 1289064 10454988 11% /vol/root/

/vol/root/.snapshot 5033164 0 5033164 9% /vol/root/.snapshot

after I rebooted the controller, I can access the filer by this URL : /filer/na_admin/

but when I try to access the “FilerView “ it was failed. " IE cannot display the webpage", "filer" is not set up establish a connection on port https with is computer.

after I switch the root vol to the old one the vol0 everything is right.

did I miss some steps?


It's possible that some of the files needed for Filerview have not been copied over correctly, from the `df` output it does appear that /vol/root contains approx 95MB less than /vol/vol0.

You can try to resolve this by downloading the 7351P1_setup_e.exe file from NOW, copying it into /etc/software and running the command `software install 7351P1_setup_e.exe`

This should install all required files in the correct locations within the root volume.


Thank you Andrc,

I was tried your solution, software update then reboot,

but the FilerView still not work, looks no https service on the controller.


Hi Andrc,

An update, I was changed the options:

options httpd.admin.ssl.enable off

now I can access the FilerView, but i was lost the authentication page.

can you help?


Given you dont have any data on the filer and the configuration for the most part will be in /etc/rc and potentially /etc/hosts why dont you just rebuild it?

If you only assign the disks you want it to use for the root aggregate in maintenance mode it will install to these.

Troubleshooting this sounds like it will cost you alot more time that a simple reinstall although you will have to zero the disks.

1. Boot into maintenance mode

2. Destroy root aggregate

3. Unassign all disks

4. Assign disks you want to be the root aggregate for controller a

5. Ctrl C the boot and select 4a to reinstall

6. Restore /etc/rc etc as required.

7. Repeat process for controller b

The NDMP copy of thew root volume works and i have done a couple now, however something about your environment is causing you issues and i would suggest troubleshooting it will take you longer than a reinstall.