The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to register at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

API service cannot save admin password at install

zsliptaii

Hi all,

 

When installing API service on Redhat 7.4 get the following error at the end:

Successfully started OnCommand API Services.
Configuring password for admin user.
Configuring password for admin user failed.
Exiting Installation ....

 

The installation finishes without any other error. I can navigate to the site, but no login is possible with the admin user.

 

Trying to change the password through change-password.sh, I get the following:
Exception in thread "main" java.lang.RuntimeException: Invalid parameter usage. Please use [-<paramName>=<value>].
        at com.netapp.apiservice.tools.command.CommandsUtil.parseInputParameters(CommandsUtil.java:70)
        at com.netapp.apiservice.tools.ApiTools.main(ApiTools.java:29)

 

Anyone experienced similar issue?

6 REPLIES 6

zsliptaii
Turns out the GA release works, but the P1-2 does not. In 2.2 it will be corrected, if you can get your hands on the old release you can install it, otherwise I advise waiting. (Maybe bug support for it.)

balaji_itility

I dont think this is correct. 

I did a first time install of GA version 2.1 and still having the same issue i.e the first time password does not work plus changing password script also faiils\

 

Balaji

 

zsliptaii

Have you tried the new 2.2RC1 release?

balaji_itility

not yet...but will do the same

gbenoist

Hello,

 

Same here:

 

# java -jar /opt/netapp/api-server/api-tools/api-tools-1.0.0.jar change-default-server-password -apiserver.password="Your_Password_Here" -port=8443
Save Password Failed. Reason: Not Found

 

Even when reinstalling the MySQL server and starting with a new, empty database.

 

 

Regards

 

eyeboxone

The installer doesn't even give an error. Appears to take the password I enter but after installation I unable to login to the web interface.I even un-installed and re-installed. Took the password again but same issue. When I run ./change-password.sh I get Password not found. I assume I am suppose to get a prompt to enter a new password. When I run  ./change-password.sh -apiserver.password=Password -port=8443, I get  Save Password Failed. Reason: Not Found.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public