Active IQ Unified Manager Discussions

Balance 4.2 permission denied against vsphere 6


Hi folks,


has anyone upgraded to vpshere 6? you may want to hold back if you use OnCommand Balance.


I just noticed that OnCommand Balance is not talking to vsphere anymore.. we get "A permission denied error occured. Please verify the configuration and credentials for this device."..

quite certain the credentials are correct as we can login with the same credentials using the web gui.


Now that OnCommand Balance is EOA.. I'm guessing it is unlikely we will see vsphere 6 support... Arguable we are on a supported config cos the matrix talks about ESX 5.5 support..and we only upgraded vsphere/vcentre to v6. 🙂

I know that OnCommand Insight is the replacement product but according the the interop matrix, it looks like that only supports up to ESX 5.1!




Re: Balance 4.2 permission denied against vsphere 6




As per the Netapp document "" it looks like Oncommand Balance support is till vSphere 5.5 The interop matrix, says that Oncommand insight  supports vSphere5.5 "" however there is no support yet for vSphere 6 as off now.



If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Balance 4.2 permission denied against vsphere 6


i then tried with my own vsphere credentials and balance was able to do the discovery.. hence it had to do with permissions and version 6 although not supported does work.


I only checked the credential stored in balance could login to the vsphere console.. and that worked fine.. what i failed to notice was that it had no access to see any of the VMs or hosts.


v6 is an appliance.. so we had to fix up/add back the permissions for the account being used in vcenter.. (it was setup correctly before the upgrade in v5.5)

View solution in original post

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums