The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to reigister at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

Can't access FAS8040 GUI through OnCommand System Manager

gavan

Hi, I have a FAS8020 cluster, v 9.3.RC1, works fine serving data, accessible through Putty,

but since a few days I cannot access the cluster via OnCommand.

 

Wenn I try to login, the sysmgr starts opening the GUI,

the following bullets start making circles

OnCommand_bullets.PNG

and that's it, it never asks me for credentials.

 

Thankful for any advise,

have a nice year!

Apostolos

ag
8 REPLIES 8

yannb

What does the following command returns?

 

vserver services web show -name sysmgr -instance

You can also try to restart sysmgr with vserver services web modify 

gavan

Hi Yann and thanks for your reply.

The output is the following:

 

DR8020::*> vserver services web show -name sysmgr -instance

Vserver: DR8020
Service Name: sysmgr
Type of Vserver: admin
Version of Web Service: 1.0.0
Description of Web Service: OnCommand System Manager
Long Description of Web Service: The OnCommand System Manager web service
Service Requirements: disco>0.0.0, ontapi>0.0.0
Default Authorized Roles: admin, readonly
Enabled: true
SSL Only: true

 

Finally the problem was solved yesterday, I had to shutdown all hosts

and reboot one of the nodes.

I hope NetApp finds a solution for this case, it's not the best practice to shut down all your hosts to regain access to the storage...

ag

yannb

When you say all the hosts, you mean the storage clients ?

 

I don't think this is what fixed the issue, but rebooting a node is more likely.

 

Does it happens often?

gavan

 

Yes, I had to shut down all ESXi servers that use the storage.

and then reboot the storage. You are right, the reboot solved the problem. 

 

// Does it happens often?

No, it is the first and only time but the customer had no access to the OCSM for about 10 days.

 

ag

qw
NetApp

Hi,

  Just a quick check, was the customer able to access OCSM after rebooting or still not able to access System manager?

 

Thanks and regards,

mahalakg@netapp.com

System Manager TME

gavan

Ηι,

 

yes, the customer was able to access OCSM after rebooting.

After rebooting just one of the 2 nodes.

We still don't know what caused the problem and if it reappears in a few weeks, but we have access again.

 

Thanks for your concern,

Apostolos

ag

qw
NetApp

Hi,

Couple of things you can try.

 

Option 1:

Try clearing the browser cache and try to login to SM using cluster-management IP

Option 2:

Is it possible to share the browser console log? (Via inspect element of browser, open inspect element console and provide the system IP and click enter)

It will be helpful to identify the root cause of the issue.

 

Looking forward to hearing from you.

 

Thanks and regards,

mahalakg@netapp.com

 

gavan

Hi and thanks for your reply,

 

Option 1: Did not help, I cleared all data and tried different browsers from different PCs, same result.

 

Option 2: When I open

Failed to load resource: the server responded with a status of 404 (Not Found)
/sysmgr/mlogscript Failed to load resource: the server responded with a status of 500 (Internal Server Error)
main.js:115 Error: Error: [object Object]
at eval (main.js:138)
at i (main.js:115)
at eval (main.js:115)
at n.$digest (main.js:115)
at n.$apply (main.js:115)
at i (main.js:115)
at r (main.js:115)
at XMLHttpRequest.w.onload (main.js:115) "Possibly unhandled rejection: {}"
(anonymous) @ main.js:115

 

Regards,

Apostolos

ag
Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public