Active IQ Unified Manager Discussions

Can't destroy vFiler - Vfiler x has an active command in progress.


Hello, I am trying to destroy a vfiler identified by

x                     stopped
   ipspace: xxx
   IP address: some ip [unconfigured]
   Path: /vol/x_root [/etc]
   UUID: 3d047278-7e3d-11dd-ab77-00a098025c22

but toaster do not let me to do so, it says

toaster> vfiler destroy x
Vfiler x has an active command in progress.

Do you have any idea where problem could be? Can I find somehow what is blocking this operation?





Can you remember any operations running on any of the vfiler context when you tried these commands?

AFAIK, only one command can be run in vfiler context.

So if there are multiple vfilers in the system, possibility is that there may be some vfiler related command is being executed.

I am not 100% sure of the behavior, people in the forum can correct me if i m wrong.




I think the command means some sort of operation from Vfiler is under progress, like DR. Can you wait till then and destroy it ?




Also worth checking if you have missed to logout from the same Vfiler context.  If such in case then you must be hitting the bug




Are you monitoring the device with Operations Manager? OM executes certain commands to pull data about a vFiler.

If you have lots of volumes or snapshots assigned to the vFiler, and you have frequent polling the vFiler will seem like its constantly processing a command.

If this is the case the best way around this I've found is to manually remove all the volumes from the vFiler (instead of letting the vFiler destroy process return the volumes to vFiler0) then wait for about an hour and try the vFiler destroy process again.



We have OM, I have done this and I still can't destroy a vFiler 😞

I have minimal resources for a vFIler

vn119_remove                     stopped
   ipspace: te1-226
   IP address: [unconfigured]
   Path: /vol/vn119_root [/etc]
   UUID: 3d047278-7e3d-11dd-ab77-00a098025c22

and I still can't destroy it 😞


I know this is quite old but I ran into this on a newer system (8.0.3P1).

The problem looked to be that I had ssh'd into the filer, then vfiler context vfilername.  I ran some commands, and then just typed exit which drops the shell.

I kept getting this "has an active command in progress" message over and over until I:

1. ssh'd into the filer

2. vfiler context vfilername

3. vfiler context vfiler0

I could then destroy the vfiler without issue.




1. ssh'd into the filer

2. vfiler context vfilername

3. vfiler context vfiler0



This worked for me!  thank you!


Do you have any snapmirror relationship for a volume in this vfiler?

If yes, break and try to destroy the vfiler.


Rodrigo Nascimento

NetApp - Enjoy it!



I heaved the same problem,

the issue was - on the (RLM/SP) shell- it was connected true this shell to the vfiler, (vfiler context <vfilername>

you will need to connect to the SP/RLM and verify that you don't connected to the vfiler on this shell

if you are connected to the vfiler you will need to run from this shell "vfiler context vfiler0"

and this will solved your problem now you can try one more time 🙂 to do the vfiler delete or destroy!

also reboot to the system or cf takeover will solved this issue 🙂 but you don't need to do it!!!

best regards,



Perfect. I would never have figured that out, thanks!



Just ran into this. Make sure that you terminate any cifs services in the vfiler context, then stop the vfiler and destroy it. For some reason it was still polling the DCs for domain access even though the vfiler was stopped in my case.



I had this problem also but this time i was unable to create a DR vfiler after DR work.   We had to DR , we recovered and then we have to " vfiler dr resync " but unknown to me i had an session open on the SP and also in the system console , and in the vfiler context.  I went back into the SP did a vfiler context vfiler0. Exited and then i was able to perform vfiler dr resync and it worked a treat :0)