Active IQ Unified Manager Discussions

Can't see any other database schema besides information_schema

jrpatrick
6,379 Views

I'm using WFA 2.0.1 and when I connect to the database using MySQL workbench 5.2, I can only see the information_schema.  I used the user wfa and blank password to connect.  I was hoping to view the tables so I could write some custom filters and possibly use the playground schema.  What am I doing wrong?

1 ACCEPTED SOLUTION

sinhaa
4,864 Views

Jrpatrick,

   Back to your original post and the problem has been found out. I was able to reproduce the issue you are facing.

This is a known bug in WFA2.0 and WFA2.0.1 that user wfa/Wfa123 is only allowed remote access and not access through localhost. So if you are using Server: localhost and credentials wfa/Wfa123 , your login will fail saying access denied.

This bug has been fixed in WFA2.1, so I suggest you upgrade to WFA2.1

But if you still want to continue with WFA2.0.1, enable remote login to your WFA db by doing the following steps:

  1. Edit 'NetApp\WFA\mysql\my.ini'
  2. Comment the last line - "bind-address=localhost" by adding a # i.e. #bind-address=localhost
  3. Save the file and close.
  4. Restart the WFA Database Service ( it will restart Server service too).

Now try to login giving IP Address of the WFA server ( and Not localhost ) and userid: wfa , Passwd: Wfa123.

This will have to work.

warm regards,

Abhishek

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

View solution in original post

17 REPLIES 17

abhit
6,362 Views

Please use username/pwd wfa/Wfa123 to access playground DB.

You can refer to the workflow developers guide for more details

https://library.netapp.com/ecm/ecm_download_file/ECMP1307539

Section "What playground database is".

-Abhi

jrpatrick
6,362 Views

The doc says WFA 2.1 and I'm using 2.0.1, will this info still apply?

abhit
6,362 Views

Yes

-Abhi

jrpatrick
6,362 Views

using user wfa and password Wfa123 it tells me access denied.

sinhaa
6,361 Views

jrpatrick,

      going back to your original problem, can you answer the following?

1. Is it an absolute new installation of WFA and your WFA is completely fresh?

2. When you were able to see only the information schema, what credentials were you trying?

3. Credentials wfa/Wfa123 work only when server address is localhost. By default remote DB login is disabled. You can enable it, by following

  1. Edit 'NetApp\WFA\mysql\my.ini'
  2. Comment the last line - "bind-address=localhost" to "#bind-address=localhost"
  3. Save the file and close.
  4. Restart the WFA Database Service.
If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

jrpatrick
6,361 Views

1. Is it an absolute new installation of WFA and your WFA is completely fresh?

I think this system had version 1.1 on previously. It was removed and 2.0 installed.

2. When you were able to see only the information schema, what credentials were you trying?

userid:wfa password: blank

3. Credentials wfa/Wfa123 work only when server address is localhost. By default remote DB login is disabled.

I have mysql workbench installed on the wfa server so all the communications I have been doing is via localhost. 



sinhaa
6,361 Views

I can now only see that you have been hit by a known bug whose cause is somewhat unknown. It happens on some rare occasions ( outside of netapp,  you have been the first case I know )  where even after a successful installation, WFA schema tables are not created.

The only way out is to uninstall this WFA and re-install. Its should work after that given the rarity of the bug's occurrence.

Your inconvenience is regretted.

Also I suggest you can use WFA2.1 version instead of WFA2.0. Its a big jump from 2.0 to 2.1

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

jrpatrick
6,361 Views

Created a brand new VM, installed 2.0.1 on it, and still have the same issues.

yaronh
6,361 Views

Hi Jrpatrick,

Just to confirm several points:

1) You have created a new VM (Which OS), installed 2.0.1 (No occupied ports right?)

2) Did you try and access WFA DB directly after installation?

3) Did you restore your backup and then tried?

4) Are you accessing the DB locally or remotely? Since remote access was not available by default.

If you restored a backup prior to trying access - I suspect something in the backup is amiss.

If not - Would be very interesting to see your backup.

Can you share it here or send it directly to yaronh ** @ ** netapp.com  (Please remove asterisks).

Thanks,

Yaron

jrpatrick
4,853 Views

1) You have created a new VM (Which OS), installed 2.0.1 (No occupied ports right?)

Windows 2008 R2 Ent.

2) Did you try and access WFA DB directly after installation?

Yes.  All I did was configure the Data Source to the DFM server

3) Did you restore your backup and then tried?

Nope.

4) Are you accessing the DB locally or remotely? Since remote access was not available by default.

locally... MySQL Workbench loaded on that new VM.

If you restored a backup prior to trying access - I suspect something in the backup is amiss.

If not - Would be very interesting to see your backup.

yaronh
4,853 Views

Was the acquisition successful? After connecting to the DFM?

jrpatrick
4,853 Views

The acquisition was successful. 

kandati
4,853 Views

When your are connecting from MySQL workbench 5.2, what value is populated in Database(s) or Default scheme field(the page where you provide the connection details)..!

Is it blank or some value is populated..!!

-Siva

abhit
4,854 Views

To further debug the issue, we have logged a defect in our defect tracking system.

Will update you about the progress of the same shortly.

-Abhi

jrpatrick
3,011 Views

I leave default schema blank.

sinhaa
4,865 Views

Jrpatrick,

   Back to your original post and the problem has been found out. I was able to reproduce the issue you are facing.

This is a known bug in WFA2.0 and WFA2.0.1 that user wfa/Wfa123 is only allowed remote access and not access through localhost. So if you are using Server: localhost and credentials wfa/Wfa123 , your login will fail saying access denied.

This bug has been fixed in WFA2.1, so I suggest you upgrade to WFA2.1

But if you still want to continue with WFA2.0.1, enable remote login to your WFA db by doing the following steps:

  1. Edit 'NetApp\WFA\mysql\my.ini'
  2. Comment the last line - "bind-address=localhost" by adding a # i.e. #bind-address=localhost
  3. Save the file and close.
  4. Restart the WFA Database Service ( it will restart Server service too).

Now try to login giving IP Address of the WFA server ( and Not localhost ) and userid: wfa , Passwd: Wfa123.

This will have to work.

warm regards,

Abhishek

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

jrpatrick
3,012 Views

that did it!  I connected with the system IP, to my original system with wfa/Wfa123 and I can see them now.

Public