The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to reigister at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

Create suid export-policy rule

john_szakacs

   I am trying to create a cDOT export-policy rule that has 'allow-suid' set to true.

   The "Create export rule" does not have a reference to the allow-suid flag

   I created a new command and extended the command code to include it:

----/--

Added the parameter:

   [parameter(Mandatory=$true,HelpMessage="Allow SUID")]

   [string]$Suid

I added it to the expression:

... -ReadWriteSecurityFlavor" + $RwRule + " -allow-suid " + $Suid

That threw an error on unknown element

Created a new definition called SZ_Export_SUID_Rule and added a line with allow-suid

Changed the parameter in the command to reference that new definition and still get the errors.

What am I doing wrong?

Thanks in advance for the help.

-John

1 ACCEPTED SOLUTION

sinhaa

John,

     WFA commands user cDOT Powershell Tookit cmdlets and not cDOT CLI commands. So for this export-rule create command, the cmdlet New-NcExportRule doesn't have any -allow-suid parameter. It uses a switch -EnableSetUid

So you can do the following:

## begin###

[parameter(Mandatory=$true,HelpMessage="Allow SUID true/false")]

   [bool]$Suid

if($Suid)

{

  $expression = "New-NcExportRule -ErrorAction Stop -VserverContext " + $VserverName + " -Policy " + $PolicyName + " -ClientMatch " + $ClientMatch + " -ReadOnlySecurityFlavor " + $RoRule + " -ReadWriteSecurityFlavor " + $RwRule + " -EnableSetUid"

}

else {

  $expression = "New-NcExportRule -ErrorAction Stop -VserverContext " + $VserverName + " -Policy " + $PolicyName + " -ClientMatch " + $ClientMatch + " -ReadOnlySecurityFlavor " + $RoRule + " -ReadWriteSecurityFlavor " + $RwRule + " -DisableSetUid"

}

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

View solution in original post

3 REPLIES 3

sinhaa

John,

     WFA commands user cDOT Powershell Tookit cmdlets and not cDOT CLI commands. So for this export-rule create command, the cmdlet New-NcExportRule doesn't have any -allow-suid parameter. It uses a switch -EnableSetUid

So you can do the following:

## begin###

[parameter(Mandatory=$true,HelpMessage="Allow SUID true/false")]

   [bool]$Suid

if($Suid)

{

  $expression = "New-NcExportRule -ErrorAction Stop -VserverContext " + $VserverName + " -Policy " + $PolicyName + " -ClientMatch " + $ClientMatch + " -ReadOnlySecurityFlavor " + $RoRule + " -ReadWriteSecurityFlavor " + $RwRule + " -EnableSetUid"

}

else {

  $expression = "New-NcExportRule -ErrorAction Stop -VserverContext " + $VserverName + " -Policy " + $PolicyName + " -ClientMatch " + $ClientMatch + " -ReadOnlySecurityFlavor " + $RoRule + " -ReadWriteSecurityFlavor " + $RwRule + " -DisableSetUid"

}

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

View solution in original post

john_szakacs

Sinhaa -

    Very helpful.  I will take a look at that toolkit for future reference.  Thanks much!

Cheers,

john

abhit

When are you getting this error?

Did you do a Discover Paramaters after you added the new parameters to the command?

Regards

Abhi

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public