Active IQ Unified Manager Discussions

Create volume



I'm creating a workflow that creates sources and destination volumes, with the required mirror, and then creates a LUN fusing Snapdrive on the server.  There are 2 issues using the included Create volume command for this workflow.


This is in cDoT, and the SVM only has the iSCSI protocol.  iSCSI does not require the volume is mounted, and in System Manager you cannot in fact see the whole namespace option.

The Create volume command in WFA does not allow the creation of a rw volume without a mount point.

There is not even an included command to unmount a volume (I have created my own to work around it).


Since Snapdrive will be controlling the snapshots, to ensure consistency, I need to disable snapshots on the volume.  However the snapshot_enabled: attribute hasn't been included in the implementation.

I haven't worked around this part yet, but I suspect it'll be either adding a command specifically to disable the snapshots, or cloning the create volume command and adding the functionality in there.

Am I missing something on the above points, or please could I add a feature request for the 2 things to be added in future versions.  If only so that I don't have to the version checking on my commands



It gets worse...

The powershell cmdlet Set-NcVolOption won't allow snapshots to be turned off for flexible read-write volumes!

I'm detecting a favouring of NAS over SAN!


I was missing something!

NetApp have created a snapshot policy called none.  Setting the snapshot policy of the volume to this policy disables the snapshots!  In System Manager this is achieved by taking the tick out of the enable scheduled snapshot copies box, hence why I was expecting to disable something.  My expectations further increased seeing the snapshot_enabled attribute!

The none policy is also disabled, causing more confusion since it doesn't appear in the drop down list of available policies in System Manager!

So another cDoT learning experience, and that part is all good... just the mounting issue remains


Slightly off-topic - does the "none" policy have to be enabled to take effect? 

I am talking in general, not just in your specific case, though if that was the case it may explain why it didn't show in the drop-down menu.