Active IQ Unified Manager Discussions

Error: Zapi::invoke failed to connect SSL

GSC

Hi All,

We recently upgraded CDOT to NetApp Release 9.7P4 with netapp-harvest version netapp-harvest-1.6-1.noarch. Now we are not getting data and the log shows:

 

[sysinfo] Update of system-info cache DOT Version failed with reason: in Zapi::invoke failed to connect SSL ; Recommend to verify TLS is enabled (7-mode: options tls.enable) an secureadmin setup ssl)

 

What would be the problem and any suggestion to fix this?

 

Thanks.

1 ACCEPTED SOLUTION

NetApp_SR

The NetApp Harvest IAG says "Harvest communicates with monitored systems exclusively via HTTPS using TLSv1".  The TLSv1 protocol may be disabled on the cluster. When FIPS 140-2 compliance is enabled, TLSv1 and SSLv3 are disabled. ONTAP prevents you from enabling TLSv1 and SSLv3 when FIPS 140-2 compliance is enabled. Check to be sure TLSv1 is enabled to allow communication.

 

cluster::>security config show

 

View solution in original post

2 REPLIES 2

NetApp_SR

The NetApp Harvest IAG says "Harvest communicates with monitored systems exclusively via HTTPS using TLSv1".  The TLSv1 protocol may be disabled on the cluster. When FIPS 140-2 compliance is enabled, TLSv1 and SSLv3 are disabled. ONTAP prevents you from enabling TLSv1 and SSLv3 when FIPS 140-2 compliance is enabled. Check to be sure TLSv1 is enabled to allow communication.

 

cluster::>security config show

 

View solution in original post

GSC

Thanks for the suggestion to check the SSL and it shows that it was disabled. I found out that the netapp-harvest certificate was expired and installed a new one and now it is working back again.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public