Community maintenance is complete. Thank you for your patience!

Active IQ Unified Manager Discussions

Failed to add crendentials to dfm

JITTU2022

Hi,

While I was adding my credentials to dfm ,

ERROR Message:

Failed to connect to DFM:

No connection could be made because the target machine actively refused it 172.xx.xx.xxx:22.

Any Help!

7 REPLIES 7

goodrum

What type of OS is DFM installed?  If this is Windows, then you need to install an SSH Server on the DFM host.  If this is a Linux install, then double check that the account you are using can SSH.  The Certified commands are designed to use SSH.  If you do not want an SSH Server installed on your DFM Server, then you would have to re-created the commands using API calls from the NetApp Manageability SDK.  If you go that route, then you can add the DFM credentials to WFA using the Type of Other.

JITTU2022

Thanks for a quick reply,

Do you any documentation or steps on installing ssh server and making using of it.

Our dfm is in Windows.

Thnks

goodrum

I haven't set it up for WFA but I have used copSSH in the past - https://www.itefix.no/i2/copssh.  There are several ports of OpenSSH server for windows and this is just one of them.  Essentially, you just need to install an SSH server on the Windows host.

bdave

If you can't install an SSH server on your Windows server running DFM, the other option is to write your WFA commands in Perl and use the NMSDK Perl modules for taking actions in DFM.  I'm 99% sure there's at least one example command of using Perl to interact with DFM built-in with WFA 2.0.

Refer to the WFA install & config guide for integrating Perl and the NMSDK with WFA.

I'd be curious which route you choose.

Thanks,

Dave

JITTU2022

Somehow, i cant able to install sshserver on dfm server. May be due to non-compliant s/w.I want to try Perl script which you are saying!

Thanks!

bdave

So you're not beating your head when you get to this...  I remember from when I set this up in WFA 1.1, creating the credentials for the DFM server (for Perl commands) produced the same error as you got above.  That's because the Test mechanism only attempts to connect to DFM using SSH (port 22).  Perl will use the NMSDK and API calls to DFM, not SSH.  Go ahead and Save the credential anyway.  (I haven't personally done this in 2.0 yet.  1.1 would let you add it even if it failed the check.) 

The DFM via Perl NMSDK certified command example is called, "Add Volume To Dataset Via Perl". 

JITTU2022

Your expression is right .

Even the 2.0 would add anyway..While it is executing it will fail tryin to connect port 22.

I have to try script ...since I am not expert at script , don't know how long it will take to work out .

thanks for your input!

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public