Effective December 3, NetApp adopts Microsoft’s Business-to-Customer (B2C) identity management to simplify and provide secure access to NetApp resources.
For accounts that did not pre-register (prior to Dec 3), access to your NetApp data may take up to 1 hour as your legacy NSS ID is synchronized to the new B2C identity.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

Getting errors when using 'Create Qtree' and 'Set Quota'

A_Campbell

I'm creating a qtree successfully with 'Create Qtree', but getting errors on the 'Set Quota' step within my workflow. The goal of my workflow is to create a new qtree (named by the user) on a volume that I've already created ahead of time. Then, set the quota on the newly created qtree using the disk limit which will be specified by the user.

Here's what I have for Create Qtree, which completed successfully:

 

create qtree.gif

 

Here's what I have for Set Quota, which is failing with the error below:

 

 

set quota.gif

 

 

Here's the error I'm receiving:

 

14:13:52.699 INFO  [Set quota] ### Command 'Set quota' in 'PERL' ###
14:13:54.196 INFO  [Set quota] Connecting to cluster: ho-0001-cnas50t
14:13:55.335 INFO  [Set quota] Credentials successfully provided for 'ho-0001-cnas50t'
14:13:55.382 INFO  [Set quota] Trying to connect to ho-0001-cnas50t using HTTPS on port 443 with timeout 0
14:13:55.913 INFO  [Set quota] Set Quota
14:13:56.646 ERROR  [Set quota] Unable to set quota for : /vol/Adam_TestVol1/test03Error -Invalid value specified for "policy" element within "quota-set-entry": "". (13115)
14:13:56.677 ERROR  [Set quota] Command failed for Workflow 'Qtree Create - Adam' with error : Can't return outside a subroutine at ./Set_quota7299545918566838944.pl line 103, <STDIN> line 1.
14:13:56.677 INFO  [Set quota] ***** Workflow Execution Failed *****

 

 

I think my problem is either with the qtree field and/or the quota_volume field. Adam_TestVol1 is the volume I created ahead of time and this is where the qtree is created in the first step. Any advice on setting the quota on the qtree would be greatly appreciated. Thanks

 

 

1 ACCEPTED SOLUTION

MattInCO

I had the same problem initially on a test. I had to fill in the “quota_policy” with an existing policy, which was “default” in my case, and then it worked. The information included makes it appear this shouldn’t be needed, but that didn’t appear to be true in my case. See if you experience the same thing.

 

Also, nifty little trick (in my opinion), once you have established your inputs in the Create Qtree command block you can reference them in subsequent blocks by using the name defined. For instance, in the Set Quota command block for Cluster you can use: qtree1.volume.vserver.cluster.name. For qtree name: qtree1.name. And so on (it auto populates as you type to help you dig in). That way if you change whether an input is a user input or statically defined, you should only have to update in the first block. This is how you reference things from “Search or Define” commands, too.

CaptureRef.JPG

 

Hope that helps some.

View solution in original post

2 REPLIES 2

MattInCO

I had the same problem initially on a test. I had to fill in the “quota_policy” with an existing policy, which was “default” in my case, and then it worked. The information included makes it appear this shouldn’t be needed, but that didn’t appear to be true in my case. See if you experience the same thing.

 

Also, nifty little trick (in my opinion), once you have established your inputs in the Create Qtree command block you can reference them in subsequent blocks by using the name defined. For instance, in the Set Quota command block for Cluster you can use: qtree1.volume.vserver.cluster.name. For qtree name: qtree1.name. And so on (it auto populates as you type to help you dig in). That way if you change whether an input is a user input or statically defined, you should only have to update in the first block. This is how you reference things from “Search or Define” commands, too.

CaptureRef.JPG

 

Hope that helps some.

View solution in original post

A_Campbell

@MattInCO

 

This is fantastic information, filling in 'quota_policy' resolved my issue, I used 'default'. Also, great tip on using notation as qtree1.volume.vserver.cluster.name. I really appreciate the help, Thanks!

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public