The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to reigister at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

How do you add a volume to a dataset by name?

ckeith

I'm trying to use a script to add of lots of volumes to a dataset within OnCommand.  From the GUI I would find the volume from the "Unprotected" window and add it to an existing dataset.  However, since there are so many I am hoping to somewhat automate it by just invoking a bunch of "DFPM dataset add" commands.  Unfortunately, I am running into a problem in that DFPM can't seem to find a volume by its name, only its ID:

C:\Users\ckeith>dfpm dataset add DS01-Kraft-LocalCopies TestAdd

Error: Could not add TestAdd to dataset DS01-Kraft-LocalCopies (2384). Reason: There is no volume, qtree, directory, host, aggregate or virtualization object named 'TestAdd'.

C:\Users\ckeith>dfm search volume TestAdd

Volumes - 2 matches

3039 TestAdd          ENAS-1-A                0.0

3040 TestAdd.snapshot ENAS-1-A                0.0

Qtrees - 1 matches

3041 -          ENAS-1-A       TestAdd

Events - 1 matches

Information 11754    vFiler Storage Unit Added 18 Mar 19:16 2379      VF01-Kraft-Dallas_Lab

C:\Users\ckeith>dfpm dataset add DS01-Kraft-LocalCopies 3039

Dataset dry run results

----------------------------------

Do: Setting deduplication schedule 'auto' on flexible volume.

Effect: Setting deduplication schedule 'auto' on flexible volume 'VF01-Kraft-Dallas_Lab:/H_TestVol' (3035)

Do: Change following options on volume VF01-Kraft-Dallas_Lab:/TestAdd(3039): [ nosnap to on ].

Effect: Change following options on volume VF01-Kraft-Dallas_Lab:/TestAdd(3039): [ nosnap to on ].

Do: Enable deduplication on flexible volume.

Effect: Enable deduplication on flexible volume 'VF01-Kraft-Dallas_Lab:/TestAdd' (3039)

Do: Setting deduplication schedule 'auto' on flexible volume.

Effect: Setting deduplication schedule 'auto' on flexible volume 'VF01-Kraft-Dallas_Lab:/TestAdd' (3039)

Added volume VF01-Kraft-Dallas_Lab:/TestAdd (3039) to dataset DS01-Kraft-LocalCopies (2384).

Any ideas why DFPM doesn't recognize the volume by its name?  I'm using DFM version 5.0.2 on a Windows 2008 server.

Any and all suggestions will be greatly appreciated.

Regards,

Keith

1 ACCEPTED SOLUTION

rle
NetApp Alumni

Hi Keith,

Did you try specifying the volume as: "VF01-Kraft-Dallas_Lab:/TestAdd"?

   - Rick -

View solution in original post

2 REPLIES 2

adaikkap

Hi Keith,

     You haven't qualified your volume names, that being the reason you weren't able to add it. If your intentions is to add multiple volumes and if they are from them same aggr/filer instead of adding the volume individually you could rather add the aggr or the filer.

This way of adding an aggr or filer to a dataset is called indirect referencing.

Regards

adai

rle
NetApp Alumni

Hi Keith,

Did you try specifying the volume as: "VF01-Kraft-Dallas_Lab:/TestAdd"?

   - Rick -

View solution in original post

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public