The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to reigister at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

How to remove a deleted SnapVault relationship from DFM Protection Manager?


Dear Community,

DFM keeps insisting that there is a deleted SnapVault relationship that it tries to recreate when I want to get a normal Conformance status. The point is, the relationship has been deleted on purpose, and DFM should just forget about it.

The error message (please see attachment) is:

Could not proceed automatically with this task. Found a deleted relationship for primary 6:/snapmirror_vol_cifs_homedir_2/- and dpReBaselineMode is set to Confirm.

Create backup relationship(s) between '6:/snapmirror_lun_exchangelog_sas_01_1/-' and '1:/snapmirror_vol_cifs_homedir'.

How can I tell DFM to stop wanting to recreate this last relationship?

Thanks in advance!





I'd suggest you try manually removing the destination from the dataset relationship using these commands on your dfm server:

dfpm dataset list -l <dataset name>

dfpm dataset relinquish <id of secondary resource you want to remove>

Then, edit the dataset and remove the secondary resource if it is still part of the dataset.


Thanks, Greg! I tried your suggestions, and unfortunately it didn't work.

I did:

  • dfpm dataset list -l 1018
  • dfpm dataset relinquish 2278
  • dfpm dataset remove 1018 2278

The result was:

"Error: Could not remove members from dataset ZS (1018). Reason: <server name>:<vol name> is not in ZS:root."

Any suggestions on how to proceed are much appreciated!




You are probably well past this problem since it's been a couple months but I came across this thread trying to find a solution to a similar issue I was having with the dfpm dataset remove command. If you don't specify a node name with the -N option the command assumes the resource you are trying to remove is in the default or root node. Since most policies don't really apply much to the root node this is often not the case. In your case since this is a SnapVault relationship the node you want to target within the policy is probably the Backup portion. To confirm this you can run the dfpm policy node list policy-name (the name of the policy assigned to the dataset in question). This should give you something similar to this:

Id   Node

---- --------------------

   1 Primary data

   2 Backup

The other option that may show in replacement or addition to Backup is DR Mirror, it all depends on the policy settings applied. In order to get the dataset remove command to work you need to add the -N Backup to your command so it should look like this:

dfpm dataset remove -N Backup 1018 2248

If you want you can add the -D command to do a dry run to see what would happen but I think this will get you where you need be. Of course assuming you are still having to deal with this and didn't just go and remove the resource via the management console. Just thought I would put in an answer to the problem in case someone else comes along and wants to script a mass dataset redesign like myself and was hoping to avoid the GUI.


Nick Barton


Hi Maarten

Can you show me the Output of the following Commands:

  • dfpm dataset list -l 1018




Hi Thomas,

the output of your command is a looooong list. What particularly are you interested in?



Is the Volume 6:/snapmirror_vol_cifs_homedir_2/- still in the Dataset?


IIRC (can't access dfm right now.), yes, it's still there.

I got this error when I tried to delete it:

  • dfpm dataset remove 1018 2278
    "Error: Could not remove members from dataset ZS (1018). Reason: 6::/snapmirror_vol_cifs_homedir_2/- is not in ZS:root."


Hi Maarten

A few question:

- Which protection Policy you have (Backup,then Mirror/Mirror, then Backup)?

- Do you have the Volumes or the Qtrees in the "Primary Data" Section?

- Do you have others snapvault Relationsships in the Volume "snapmirror_vol_cifs_homedir_2" which you want to keep?



NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner