Active IQ Unified Manager Discussions

How to upgrade DFM version 4.0 to latest Operation Manager version?


We are currently  running DFM ver 4.0D14 on windows 2003 server (32-bit) .

We want to migrate the this old DFM from windows 2003  to new windows host (windows 2008 64-bit) and the database able to restore to the new server.

However i am not able to upgrade the DFM version (4.0 to 5.0). It just hung during the installation page.

What is correct process to upgrade our old ver4.0 to newer version ? If you have any comments or suggestion , I appreciate.  Thank you in advance.



Hi Christy, 



I would suggest to install the new version of DFM on your new windows machine ( WIN 2008 ) and restore your OLD DFM DB to it, Procedure as follows...



Prerequisite:-   Have a copy of your DFM license and keep it safe 



                           dfm license list 





Stop/Start services as below


dfm service stop 



dfm service start sql 



dfm backup create -v



Note :- This creates a backup file (.ndb format) which is stored in the <install_dir>\Netapp\DataFabric Manager\DFM\data folder.




Disable any monitoring or purging 




dfm option set discoverEnabled=No



Windows: for /f "tokens=1" %i in ('"dfm host list -a | findstr /I "yes""') do dfm host delete -f %i | echo HostID=%i



Perform another backup 



dfm backup create -v 


Note:- This creates a backup file (.ndb format) which is stored in the <install_dir>\Netapp\DataFabric Manager\DFM\data folder



Copy the .ndb file to a safe location to be use to restore on to the new server 



Now login to the new windows machine ( Windows 2008 ) 



Install the new version of DFM 



Restore the backup 



dfm backup restore <path-to-dbfile>



Change the new server DNS names to olddfm.local ( In case if required ) 


Once done , Start all the DFM services 



Note:- If you think you have huge number of mark-deleted objects , use purge tool to purge all the deleted objects 




DFM Purge Tool Download



DFM Purge Tool Usage Doc









**** If my reply helped you to solve your issue, Please help to mark it as solutions to help others****




HI Nayab,


This is the first attempted we tried whereby the new server Win 2008 installed with latest DFM version. However the restore DB was failed and we tried several of attempts.


Now the new server is able to run with the old DB restore data. But we are stuck on how to upgrade it  to newer version. Any idea?




Hi Christy, 




Sorry, I have missed out that you have already tried to do it , Could you check the windows logs ( Application logs ) and look for the exact error ?







**** If my reply helped you to solve your issue, Please help to mark it as solutions to help others****



There's no error on the application log(event viewer). The installation ran half way and it went into the hung state. The version i try to upgrade is 5.2.1P1.


From dfm.log it seems hung durng the cleaning the history tables.


Jul 21 04:36:25 [dfm: INFO]: [8676:0x25e4]: Stopped sql service
Jul 21 04:39:07 [dfm: INFO]: [10164:0x27c4]: Started sql service
Jul 21 04:39:13 [dfm:DEBUG]: [9140:0x3f8]: Attempting cleanup of the database
Jul 21 04:39:13 [dfm: INFO]: [9140:0x3f8]: Beginning pre-purging setup
Jul 21 04:39:13 [dfm: INFO]: [9140:0x3f8]: Disabling the backup schedules
Jul 21 04:39:14 [dfm: INFO]: [9140:0x3f8]: Stopping services other than sql
Jul 21 04:39:14 [dfm: INFO]: [9140:0x3f8]: Setting up the scripts for purging...
Jul 21 04:39:36 [dfm: INFO]: [9140:0x3f8]: Calling procedure to truncate tables...
Jul 21 04:39:36 [dfm: INFO]: [9140:0x3f8]: Tables truncated successfully...
Jul 21 04:39:36 [dfm: INFO]: [9140:0x3f8]: Calling procedure to update the triggers...
Jul 21 04:39:41 [dfm: INFO]: [9140:0x3f8]: Procedure to update the triggers Success
Jul 21 04:39:41 [dfm: INFO]: [9140:0x3f8]: Completed pre-purging setup
Jul 21 04:39:41 [dfm: INFO]: [9140:0x3f8]: Cleaning the history tables in the database
Jul 21 04:39:41 [dfm: INFO]: [9140:0x3f8]: Using 2016-07-18 04:39:13.977000 as the threshold for history pruning
Jul 21 04:39:41 [dfm: INFO]: [9140:0x3f8]: Step 1/16 - Cleaning up table historyYear
Jul 21 05:45:21 [dfm: INFO]: [9140:0x3f8]: Purged 3086054 rows from table historyYear
Jul 21 05:45:21 [dfm: INFO]: [9140:0x3f8]: Step 2/16 - Cleaning up table cpuHistoryYear
Jul 21 05:46:27 [dfm: INFO]: [9140:0x3f8]: Purged 67474 rows from table cpuHistoryYear
Jul 21 05:46:27 [dfm: INFO]: [9140:0x3f8]: Step 3/16 - Cleaning up table aggrHistoryYear
Jul 21 05:49:01 [dfm: INFO]: [9140:0x3f8]: Purged 177145 rows from table aggrHistoryYear
Jul 21 05:49:01 [dfm: INFO]: [9140:0x3f8]: Step 4/16 - Cleaning up table dfHistoryYear


Also, i was unable to start others services or even stop the sql services.  Please advice

>dfm service list
sql: started
webui: not started
http: not started
eventd: not started
monitor: not started
scheduler: not started
server: not started
watchdog: not started


Hi Christy, 


May i know the version of 







As i see the upgrade is trying to delete the expired or stale data, Could you run PURGE tool and then try to perform the upgrade once again ?


After running Purge tool perform a reboot and then try to upgrade.






Details as below:


ONTAP 7-mode


JAVA version 1.6.0_45


As the installation runs half way, the dfm version show it already upgraded. My server running on Window 2008 R2 64-bit. May i know which PURGE tool i shall download? I dont see a version which matches my current version i have.


E:\Apps\NetApp\DataFabricManager\DFM\bin>dfm version
dfbm.exe (5.2.1P1)
dfdrm.exe (5.2.1P1)
dfpm.exe (5.2.1P1)
dfm.exe (5.2.1P1)
dfmcheck.exe (5.2.1P1)
dfmconfig.exe (5.2.1P1)
dfmconsole.exe (5.2.1P1)
dfmmonitor.exe (5.2.1P1)
dfmperf.exe (5.2.1P1)
dfmscheduler.exe (5.2.1P1)
dfmserver.exe (5.2.1P1)
dfmwatchdog.exe (5.2.1P1)
eventd.exe (5.2.1P1)
grapher.exe (5.2.1P1)


I tried to download and run it, however getting this error. Shall i downgrade it back to dfm 4.0, run the purge tool and upgrade again?

E:\Apps\NetApp\DataFabricManager\DFM\bin>dfmpurge help




IIRC there is no (supported) way to upgrade from 4.0 to 5.2 directly. Too many DFM and especially Sybase versions inbetween.


As 4.0 is 32bit only and 5.2 is 64bit only, there are also data conversion issues when trying to restore the 4.0 DB backup into a 5.2 instance, which may be the problems you see.


The one way that used to be supported was to upgrdae 4.0 to the latest available 32bit version, which was 5.1. Then convert 32bit to 64bit by importing the 32bit DB into the 64bit version of the same release and afterwards upgrade that version to the latest DFM / Operations Manager 5.2.


Unfortunately all versions prior to 5.2 are EOA and EOS for a very long time now, so you are on your own.


Nevertheless I still found a 5.1 releas on the support site:


Good luck.



regards, Niels





If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO or both.