The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to register at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

NetApp Harvest and Grafana dashboards

gpallis

Hello. I have some questions regarding Harvest and Grafana. Right now I 'm running version 1.4 and want to upgrade to version 1.4.2. I saw in the release notes that new dashboards for Grafana have been implemented.

 

Will re-importing the dashboards cause duplicates? Documentation says that existing dashboards of the same name will be overwritten. What happens with the data collected so far for those dashboards?

 

Thanks,

G

1 ACCEPTED SOLUTION

Buki

not sure if it's applicable to all of you, but for the archives: I had the same problem, update of grafana from 6.3.2 to 6.3.3 fixed it for me.

View solution in original post

25 REPLIES 25

yannb

Hello G,

 

The upgrade of Harvest is pretty safe for existing data.

 

First of all, regarding the actual performance data, this all happens in Graphite,a nd Harvest isn't touching, except to add new metrics, so a Harvest upgrade will never remove performance and capacity data.

 

Regarding your dashboards, you might have noticed that Harvest dahboards have special tags on it :

Screenshot 2019-05-01 at 16.13.57.png

 

Only dashboards having these tags will be deleted and replaced (again, without touching the actual data), so if you have any dashboards of your own without these tags, they are safe as well.

 

Hope this helps.

gpallis

Thanks Yann. I 'll give it a go and report back. My Harvest host is a VM anyway so I can snapshot it before the update.

gpallis

Oh, one other question that is not strictly related to Harvest, but it's more about Grafana. Any idea why for certain dashboards when I select anything different to All, I see no data? For example see below screenshot:

2019-05-01 17_42_22-Grafana - NetApp Dashboard_ Cluster.png

But when all clusters are selected then no problems at all:

2019-05-01 17_50_22-Grafana - NetApp Dashboard_ Cluster.png.

Thanks,

G

bkamil

Try a single cluster, but use one of those that are visible in the stat tables when using "All".

That specific one you just tried (not showing any data) might not have any statistics collected.

 

gpallis

Hi bkamil. That's not the case. And as I said I have noticed that behaviour with some of the other dashboards, eg the one for volumes. May be that's a Grafana bug. I have to update the host anyway to get new versions of all the software components. I 'll see how that goes and report back. Thanks

gpallis

The upgrade went well including (re-)importing (and adding) the (new) dashboards, however I still have the issue described in one of my previous posts when selecting a single resource in a Grafana dashboard. I 'll take that with the Grafana community, unless if somebody else has seen that behaviour before and found a solution. Thanks for the help all Smiley Happy

yannb

I'm afraid the Grafana community won't be able to help, it has to be related to the data.

 

Can you share another screenshot of a cluster that displays data in "All", but nothing when selected ?

 

 

JohnathanIT

Hi,

 

I'm experiencing exactly the same phenomenon. 

Working with netapp-harvest+carbon+graphite+grafana as recommended in Netapp's manual. 

When selecting ALL (or *), it shows all the data

When selecting a specific  group\cluster\svm\vol, no data is showed. 

 

Images below:

 

All selectedAll selectedGroup selectedGroup selectedCluster selectedCluster selected

 

 

 

yannb

Do you have other groups in the menu ?

 

Could it be a privilege issue in the whisper directory ?

JohnathanIT

@yannb wrote:

Do you have other groups in the menu ?

 

Could it be a privilege issue in the whisper directory ?


I have 2 groups in the menu, 

 

Whisper directory permissions:

drwxr-xr-x. 5 carbon carbon 46 May 2 18:30 whisper

yannb

So if you select one group, you see no data, if you select the other, you see no data, and if you select All, you see data ?

 

What's the content and permissions of whisper/netapp/perf ?

JohnathanIT

@yannb wrote:

So if you select one group, you see no data, if you select the other, you see no data, and if you select All, you see data ?  - Exactly.

also, if i select ALL(*) groups, i can select 2 volumes and it shows "only" both of them (even from different groups) but never a single anything.

 

What's the content and permissions of whisper/netapp/perf ?  

whisper/netapp/perf content and permissionswhisper/netapp/perf content and permissions

 


Thanks for the help! 🙂

yannb

Are there any characters that would be considered "special" in object names ?

JohnathanIT

@yannb wrote:

Are there any characters that would be considered "special" in object names ?


The group names contain capital letters, does it count as special?

Other then that, there are hyphens "-" in the cluster\node\vol names...

 

Nothing else...

zsliptaii

Have the same error, hopefully there is a solution soon.

(I think it's problem with the dashboards.)

JohnathanIT

I also think it's a problem with the dasbhoard, 

When going to "Explore" in grafana,  you can select whatever single metric you want...

 

Now i just neet to learn the grafana syntax as well 😄

zsliptaii

What Graphite version are you using?

I have 0.9.16.

It's possible that this is a Graphite bug.

Buki

not sure if it's applicable to all of you, but for the archives: I had the same problem, update of grafana from 6.3.2 to 6.3.3 fixed it for me.

View solution in original post

zsliptaii

Indeed, the new version solved the problem.

JohnathanIT

yes, 

The update solved everything.

 

Thanks for all the help 🙂

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public