The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to register at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

OCUM 6.4RC-P1 does the certificate change breaks reverse proxy for everyone in Windows and RHEL?

GidonMarcus

Hi

 

 

Just wondered if i'm the only one keep hitting this (don't try on your PROD!) .

on Windows server. just download the existing CSR gives a file with the output

 

 

Files\NetApp\ocum\bin\..\..\essentials\rp\security\san_ext.txtkeytool error: java.lang.RuntimeException: java.net.UnknownHostException: <IP> Files\NetApp\essentials\rp\bin\..\..\rp\security\san_ext.txt

And when generating a new self singed the proxy server refuse to load

 

 

 

The NetApp OnCommand Reverse Proxy service failed to start due to the following error: 
NetApp OnCommand Reverse Proxy is not a valid Win32 application.

 

 

in RHEL, I was also giving up with the reverse proxy not starting after importing a certificate (seems like the cert not copied to the key store. and fiddling with the scripts was not giving much out).

 I’m about to give up as it’s so fragile and I don’t want to put it as is in prod. Maybe I better just plain with the self-sign.    will appreciate if someone can confirm if it did work for him and how. and if so maybe i will keep trying.

 

Thx

Gidi Marcus (Linkedin) - Storage and Microsoft technologies consultant - Hydro IT LTD - UK
1 ACCEPTED SOLUTION

GidonMarcus

For windows the solution was installing in non-default folders (not in "program files"), i suspect the product didn't pass a variable correctly to openssl and the space was dropping out from the parameter.

Gidi Marcus (Linkedin) - Storage and Microsoft technologies consultant - Hydro IT LTD - UK

View solution in original post

1 REPLY 1

GidonMarcus

For windows the solution was installing in non-default folders (not in "program files"), i suspect the product didn't pass a variable correctly to openssl and the space was dropping out from the parameter.

Gidi Marcus (Linkedin) - Storage and Microsoft technologies consultant - Hydro IT LTD - UK

View solution in original post

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public