Active IQ Unified Manager Discussions

OCUM 6.x on VMware Fusion howto


i tried to get the ovf running on my mac with Fusion, but it always stucks on applying the customized ip settings.

- at first it failed to get an IP Address via dhcp

- if i try to change ip settings with the command 2

     changing the parameters for my environment

     it fail on applying the settings, because it is not reachable on configured IP

if i check the Interface IP Settings (eth0) shows a configuration without Network, Gateway and DNS Nameserver

Then i used the Options 2) Changing IP Address Settings to do the settings again,

Are these settings correct? y

9 Commit Changes

Do you want to commit the changes? y

... take some seconds an come back with

Note: Commit failed due to an unexpected error.

The pending changes made in the maintenance console have been discarded.


during the apply changes process i saw some successful pings getting through, after the error silence again...


wtf is going on in the background, why there is no access to the host itself, looks like the bs script is not properly working !


any idea ??


Re: OCUM 6.1 on VMware Fusion howto



>i tried to get the ovf running on my mac with Fusion,

This would result in an unsupported configuration of OCUM6.X

OCUM 6.X is supported only for VMware ESX deployments

Please refer the latest supported configuration matrix on IMT site (



Re: OCUM 6.1 on VMware Fusion howto


not very helpful, thank you, but i do not like to go in production with this, so thats not the problem...;(

so why it should not be possible to get this bs vmdk running on fusion, the ontap sim vmdk (okay 8.2) is also usable on fusion.

Re: OCUM 6.1 on VMware Fusion howto



>so why it should not be possible to get this bs vmdk running on fusion,

VMware tools present on VMware ESX server are bit different from VMware tools of VMplayer/Fusion.

HGFS host guest filesystem drivers in VMware tools fails while we bootup the ova

and we also see the networking drivers(vmxnet3) not working with fusion/vmplayers

ocum6.x is supported only on VMware ESX servers today.

there is a plan for alternate  installers in upcoming release similar to OCUM 5.x



Re: OCUM 6.1 on VMware Fusion howto


okay, i think if you want to push CONTAP you should go forward with this, lets wait a while until you are ready to go with this environment

should be not so tricky to respekt this on exporting the vm to the ova ?!

Re: OCUM 6.1 on VMware Fusion howto


FWIW, I got OCUM 6.0 running under VMware Fusion and also later upgraded to 6.1. I think I hit the same problem trying to change network parameters but in my case it successfully obtained a DHCP address and I've just lived with it that way. Good enough for learning and testing in a Fusion-based lab environment. This ought to a supported option.

Re: OCUM 6.x on VMware Fusion howto


6.2 still not available for vmWare Fusion, poooor ;(

whitch tatically decision is behind

- ONTAP 8.3 for fusion

- OCUM 6.x only for ESX


just split brain development ?

->  so that looks like netapp developers are not really working together with the same target !? 

Re: OCUM 6.x on VMware Fusion howto


bs guys this will also occure on ESX ;( so this is a general issue since many OCUM OVA Versions, still not fixed, poor quality ;((

will always fail with 

NOTE: Commit failed due to an unexpected error


sorry, but this is NOT a 6.4P1 Version this is still Beta 


and that's the trick ?! why this is not done on the OVA Appliance since the beginning of...


as the customer we do NOT have access to the CLI of the Appliance, so YOU should fix this before.



or just do the hack with the diag user

Launch the OPM console.

Log in as a maintenance user from the VMware console.

  1. In the Main Menu, type 4 to select Support/Diagnostics.
  2. To access the diagnostic console, type erds at the command prompt .You are prompted with the following message: Remote diagnostic access is disabled. Would you like to enable remote diagnostic access? (y/N).
  3. Type y to enable remote diagnostic access.
  4. When prompted, enter a new UNIX password for the diagnostic user.
  5. Type x to exit the maintenance console.


Launch the OPM console.

Login as User diag with the UNIX pwd

Enter the Diag Shell


Run 'sudo' 

1. VMware Host-Guest Filesystem no

2. The vmblock no

3. caf no

sudo reboot

View solution in original post

Re: OCUM 6.x on VMware Fusion howto


Though this thread is in reference to OCUM 6.x, a quick solution I found to get OCUM 7.1 OVA installed was to use a number of the details in this thread together (plus an extra step).  There were two issues I had to overcome to get this installed.  First, getting VMware Tools to install.  Second, being able to adjust network settings.  Both issues prior to the certificate being generated by the installation process.


In my situation, I was importing the OVA into VMware Fusion v8.5.3. Once the OVA was imported, the OS was identified as 'Other'. If you boot the VM at this point, the first item you will be prompted to do is to select 'Install VMware Tools' so the installation can proceed. With the OS identified as 'Other', the 'Install VMware Tools' option will be greyed out and not available.


To get this to work and the installation to proceed, I changed the OS (Settings - General - OS) from 'Other' to 'Linux - Debian 7.x 64-bit'. After powering on the VM, I was able to select 'Install VMware Tools' when prompted. I did get a mesage indicating the 'CD-ROM door is locked by the guest operating system', but specified 'No' to Disconnect anyway and override the lock?' question.


Once VMware Tools were installed, but before setting the Timezone, ‘Restart’ the VM (Virtual Machine - Restart) and proceed with booting to command prompt. For a good illustrated series of these steps, you should review  before proeeding. You will want to interrupt the boot process by pressing ‘e’ and change ‘console=tty2 quiet’ to ‘init=/bin/sh’. Then press <CTRL-X> to continue the boot process.  Remount ‘/‘ with read-write access (mount -o remount,rw /).  Edit '/etc/init.d/vmware-tools' and search for the line ‘is_vmhgfs_needed() {‘, then insert ‘echo no’ below the line and save the file. This change should allow for network settings to be applied.


Next, edit ‘/opt/netapp/ocum/scripts/’ and search for the line ‘/opt/netapp/ocum/scripts/’. Insert ‘#’ at the beginning of the line to comment it out. This will ensure VMware tools will not ‘re-install’ at startup and wipe out the vmhgfs adjustment just performed in /etc/init.d/vmware-tools.


With these two files changes, restart the VM again (Virtual Machine - Restart).


The startup will not ask to install/re-install VMware Tools and it will also not ask you to set the Timezone, so remember to set your timezone after the installation is complete.


In my situation, I was then prompted to set my static IP address details. Once entered and accepted, the ’Network configuration completed’ message was displayed, SSL certificate generation was performed and OCUM services started. I then set my maintenance user/password and proceeded to access the OCUM web page to specify my simulator cluster.


For my configuration, I did not need OCPM installed (for my testing of OCWFA workflows).  This said, I wanted to confirm if the same approach would work.  Using the same process described above for OCUM, I was able to get OCPM 7.1 OVA installed in VMware Fusion. For reference, the script locations ‘/etc/init,d/vmware-tools’ and ‘/opt/netapp/ocf/scripts/’.


Re: OCUM 6.x on VMware Fusion howto


hi rob,

thanks for your update, nice to see that i am not alone in the grey 😉

yes there are different ways to get the target, in my environment i have done the 7.1 with the old 6.4 howto and it was working fine also. I do not decide to disable the vmware tools because i expect some performance issues. Yes you can install vmware tools without identifying the OS by just mounting the linux.iso manually.

Intresting thing on OCPM OCUM is getting the right certificate at startup, because they start ssl cert create even the setup fails, and reset cert via maint console is not properly working.


I am also fine with your solution and if it is helpful for any other people to get the goal, thats worth the thread !!

At the moment i struggled with usind cDOT 9 on Virtualbox (yes there might be reasons to use virtualbox because of restrictions of the workstation!).


have a nice experience in the netapp universe and thanks again for your hints.


best regards


Re: OCUM 6.x on VMware Fusion howto


To avoid having to make those file level edits, you can just enable shared folders in the VM settings. Virtual Machine->Settings->Sharing: check "Enable Shared Folders"



If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Earn Rewards for Your Review!
GPI Review Banner
All Community Forums