Active IQ Unified Manager Discussions

OCUM 7.0 Failed to import report, Error occurred while validating the report.

tuncay

Hi,

 

I created custom report but can not upload OCUM and getting 'Failed to import report. Error occurred while validating the report. Some unexpected internal server error occurred. See log for more details.' When I check from support bundle oncommand-um-logs-ocum-report.log, there is no error message about imported reports.

 

I checked custom file, my reports was showing on that file but can not see on OCUM imported reports page.

 

Does anyone create custom report on OCUM before and got this error ?

 

Thanks,

Tuncay

 

 

1 ACCEPTED SOLUTION

tuncay

Finally I solved the problem .

 

The report which I created on BIRT has same column name.You can view report from BIRT but when you want to import OCUM, you got errors.

 

After I modfied column name, I can able to import report to OCUM.

 

Tuncay

 

 

View solution in original post

8 REPLIES 8

tuncay

Finally I solved the problem .

 

The report which I created on BIRT has same column name.You can view report from BIRT but when you want to import OCUM, you got errors.

 

After I modfied column name, I can able to import report to OCUM.

 

Tuncay

 

 

View solution in original post

EricRB

Tuncay,

 

Can you explain in a little more detail what the fix was? I started getting the same message with OCUM 7.1 while importing custom reports. 

Nagar

Hello Champs ,

 

Did you get any solution of this issue ? i am getting the same problem .

tuncay

Hello,

 

Like I said before, my query has wrong state then ı figured it out and fixed that then it solved.

 

If you send your query, I can check if it the same mistake.

 

Thanks,

Tuncay

TSUNIXBACKUP

Hi

 

I have the same problem , I send you the query 

 

select aggregate.clusterId,aggregate.name,aggregate.sizeTotal
from aggregate

 

and my error message

 

2017-09-27 10:37:32 [FATAL] [default task-34] [ReportRestApiHandler:142] - Illegal arguments passed.
java.util.regex.PatternSyntaxException: Illegal/unsupported escape sequence near index 5
.*C:\luns_2017-09-27_10_37_32-035.*

 

I have ocum intalled in linux server 

tuncay

Hi,

 

My mistake is about the query. If you can send t your query I can check yours.

 

Thanks,

 

Jeff_Yao

try to check ocumserver-debug.log

to check from basics. like: 

1. put the report file at default location: C:\Program Files\NetApp\ocum\reports\repository\public

2. report files should have "everyone" "read" and "read and execute" permission

 

 

hopefully helps

tuncay

I also tried this but it did not work but did not change the permission.

 

Now I put report to the custom and changed the permisson to everyone but result is same.

 

I checked report log file but it is empry. I could not find ocumserver-debug.log file.

 

 

 

 

 

 

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public