The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to reigister at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

OnCommand 3.1.1 fails to install

steve_waggott

I'm trying to install OnCommand 3.1.1 on a Windows 8 (64bit) workstation.

 

It pops up with a "requires 64-bit java 7 software. Only 64-bit java 8 is detected" message so I went to Java and got the 7 64-bit runtime.

Now in my installed softwared I have both a "Java 7 Update 72 (64-bit) and Java 8 Update 25 (64-bit) listed.

In the Java control panel under Java runtime envirment settings I have the two listed installs 1.8 1.8.0_25 & 1.7.0_72, I've tried unticking the enabled box on 1.8 but it still doesn't work, from what I can see both versions are installed to their default locations...

 

Any ideas?

1 ACCEPTED SOLUTION

hariprak

Hi,

 

To install OnCommand system Manager 3.1.1, Oracle Java Runtime Environment (JRE) 7 must be installed.
The Java cache must be cleared.

Remove Java 8.x and then revert to the version of Java that was working before the update to 8.x. If you are unsure what version was being run before the update, download Java 7u45 64bit, or 7u65 64bit.

Future instances of OnCommand System Manager are expected to function with Java 8.x.

If issue exists even after reverting to Java 7u65 64bit or 7u45 64bit, perform a manual uninstallation.

 1. Uninstall all Java versions listed in Control Panel/Program and Features.
 2. Make a backup of registry key HKEY_LOCAL_MACHINE\SOFTWARE\Javasoft.
 3. Delete the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Javasoft and all of its subkeys.
 4. Rename Java folder to Java.bak inside both %ProgramFiles% and/or %ProgramFiles(x86)%.
 5. Download and Install either Java 7u65 64bit or 7u45 64bit here.
 6. If launching OnCommand System Manager is successful, remove backups made in steps 2 and 4

 

Thanks

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

View solution in original post

5 REPLIES 5

Sho9

Just uninstall JAVA from your appwiz.cpl & run jre-7u65-windows-x64.exe from http://www.oracle.com/technetwork/java/javase/downloads/java-archive-downloads-javase7-521261.html#jre-7u65-oth-JPR

hariprak

Hi,

 

To install OnCommand system Manager 3.1.1, Oracle Java Runtime Environment (JRE) 7 must be installed.
The Java cache must be cleared.

Remove Java 8.x and then revert to the version of Java that was working before the update to 8.x. If you are unsure what version was being run before the update, download Java 7u45 64bit, or 7u65 64bit.

Future instances of OnCommand System Manager are expected to function with Java 8.x.

If issue exists even after reverting to Java 7u65 64bit or 7u45 64bit, perform a manual uninstallation.

 1. Uninstall all Java versions listed in Control Panel/Program and Features.
 2. Make a backup of registry key HKEY_LOCAL_MACHINE\SOFTWARE\Javasoft.
 3. Delete the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Javasoft and all of its subkeys.
 4. Rename Java folder to Java.bak inside both %ProgramFiles% and/or %ProgramFiles(x86)%.
 5. Download and Install either Java 7u65 64bit or 7u45 64bit here.
 6. If launching OnCommand System Manager is successful, remove backups made in steps 2 and 4

 

Thanks

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

View solution in original post

Sho9

No need to play with registery also. Just uninstall JAVA from your appwiz.cpl & run jre-7u65-windows-x64.exe from http://www.oracle.com/technetwork/java/javase/downloads/java-archive-downloads-javase7-521261.html#jre-7u65-oth-JPR

DETMOLD_PACK

Thanks that fix my issue.

steve_waggott

Ok I tried just uninstalling java 8 which got the installer working but still wouldn't launch the program once installed.

I uninstalled my Java 7 u72, cleared the cache then deleted the install folders and registry, installed Java 7 u65 and now it launches ok.

Have since installed Java 8 back on and still works ok although Java 8 tried to remove older versions.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public