The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to register at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

OnCommand System Manager 3.1.1 doesn't tolerate Java 8 Existence

bsnyder27

Per a Java.com recommendation, I upgraded to the java 8 jre for Windows this morning.  Afterwards, System Manager gave errors that it could not authenticate securley.  

 

After uninstalling java 8, functionality was restored.

 

Any ideas on how to force System Manager to use the java 7 client w/ the java 8 client installed as well?

26 REPLIES 26

txalamar

As stated in doc. JRE must be installed not Java SE.

 

Install suscessfull.

aborzenkov

JRE must be installed not Java SE.

I do not understand it. There is Java SE Runtime Environment and Java SE Development Kit. Both are Java SE. Can you explain what you mean?

txalamar

> java -version

java version "1.8.0_71"

Java(TM) SE Runtime Environment (build 1.8.0_71-b15)

Java HotSpot(TM) Client VM (build 25.71-b15, mixed mode)

 

and then the message OnCommand System Manager requires you to install a 64-bit Java 8 or 64-bit Java 7 software.

 

 

Please help.

aborzenkov

Try different browser. I have the same issue generally with IE11, it is not limited to OCSM.

wrandym

This is flipping ridiculous.  Come on NetApp...get your stuff together

yuvaraju

Did you try with 3.1.2 RC2. 3.1.2 RC2 has Support for Oracle Java Runtime Environment (JRE) 8

DannyP

Yes we have. We have a project installing all new NetApp filers and disk, and the NetApp consultant showed us a workaround by installing the Java 7 development kit. 

While it worked, and we were able to uninstall that version of Java and install the newest version, NetApp is largely a development company and that is really sloppy. 

PatricK_GHL

I am able to force the jar file to load from Java7 version.

 

My system is Win 7 x64, IE11 with both Java 7 update 75 (J7) and Java 8 update 31 (J8) installed, (both i586 and x64 versions). Installing does require removal of all J8, but once installed System Manager 3.1.1, J8 can be resinstalled.

 

The shortcut created by the installer won't launch after J8 is installed. Because the shortcut to java.exe is pointing to the J8 instead of the J7, checkout the shortcuts in C:\ProgramData\Oracle\Java\javapath. This is how the SystemManager.exe launches the jar file!

 

The trick here is to make a new Shortcut to the jar file the shorcut actually launches and the way to close it.

 

Path of SystemManager.jar file for NetApp: %ProgramFiles%\NetApp\OnCommand System Manager

Path of java.exe for J7: %ProgramFiles%\Java\jre1.7.0_75\bin

Path of java.exe for J8: %ProgramFiles%\Java\jre1.8.0_31\bin

 

Now right click on desktop and New -> Shortcut, then paste in below and adjust with your paths:

"%ProgramFiles%\Java\jre1.7.0_75\bin\java.exe" -jar "%ProgramFiles%\NetApp\OnCommand System Manager\SystemManager.jar"

Click Next, rename it to same name as the one created by NetApp, click Finish.

Right click on this New shortcut, under Shortcut tab, click Change Icon, browse to the folder of the NetApp SystemManager.jar, select Application.ico, click Open. Then click Ok twice.

 

Now you have a working shortcut to it. The only trouble is, after you close the browser the jar file was launched, you need to press Ctrl-C in a command prompt to close the java.exe session. Or use End Process on Task Manager.

 

If you don't close the java.exe session, it will complain on next launch.

 

Patrick.

WarAmp

It's 2015, we shouldn't have to be doing workarounds for this kind of stuf...  We spend millions on this brand and can't get important tools like this to work with our up to date secured OS's

NIHAndrew

Uninstalling Java 1.8.31 (32-bit, not sure if 64-bit would work), and reinstalling Java 1.8.31 32-bit worked for me (as of this writing 1.8.31 is the latest).  SysMgr 3.1.1.  I'm on Windows 2008r2 64-bit.  I have no other Java version in this box.

I had to do this after updating DFM (OnCommand Core) because of an Apache vulnerability.

(Yes, it is a pain to do this, but have limited choices 😞

raytheondenham

If you run it using the .jar file instead of the .exe file it will work using Java 8.

 

"C:\Program Files\NetApp\OnCommand System Manager\SystemManager.jar"

NDX

Hello bsnyder27,

 

could you find a solution for this? We are having the same problem now.

 

 

bsnyder27
Only to uninstall java 8 and go back to the latest release of java 7.  

 

 

 

hariprak

Remove Java 8.x and then revert to the version of Java that was working before the update to 8.x. If you are unsure what version was being run before the update, download Java 7u45 64bit, or 7u65 64bit.

Future instances of OnCommand System Manager are expected to function with Java 8.x.

If issue exists even after reverting to Java 7u65 64bit or 7u45 64bit, perform a manual uninstallation.

 1. Uninstall all Java versions listed in Control Panel/Program and Features.
 2. Make a backup of registry key HKEY_LOCAL_MACHINE\SOFTWARE\Javasoft.
 3. Delete the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Javasoft and all of its subkeys.
 4. Rename Java folder to Java.bak inside both %ProgramFiles% and/or %ProgramFiles(x86)%.
 5. Download and Install either Java 7u65 64bit or 7u45 64bit here.
 6. If launching OnCommand System Manager is successful, remove backups made in steps 2 and 4

 

Thanks

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

JanPaiva

Dear All,

 

For me here , the only way I found to get it back working was:

 

1 - Unsinstall all Java versions installed in my computer.

2 - Uninstall OnCommand

3 - Delete the Reg key related to Java ( mentioned in the post here above)

4 - Delete the Netapp folder created during OnCommand Installation

5 - Restart computer

6 - Reinstall Java JRE 7 x64

7 - Reintall OnCommand 3.1.1

 

 

Any other sequence listed in any of the posts here didn't work.

Please let us know if it this sequence of actions worked for you too.

 

Regards,

Jan

DannyP

Has it been pointed out that forcing customers to retrograde to unsafe versions of Java is completely unacceptable? Is there an actual fix for this? 

yuvaraju

The next version of 3.1.2, targeted for end of March or early April, will officially support Java 8.

James_C_Owens

The following worked for me with 3.1.2...

 

Put this in the target field under the shortcut tab for the icon.

 

"C:\Program Files\Java\jdk_latest\bin\java.exe" -jar "C:\Program Files (x86)\NetApp\OnCommand System Manager\2.0\SystemManager.jar"

 

You should use the actual path for the 1.8 java.exe and the SystemManager jar as it may be different for you than me.

 

Jim

(Clearly you had to already have installed SystemManager before installing Java 1.8, as the install routine itself will fail with Java 1.8. I haven't experimented with trying to get the install routine working...)

 

Netapp needs to get this fixed, as Oracle is about to stop updating Java 7 for security patches.

 

Jim

JanPaiva

Didn't work for me though.

 

Anybody namaged to find a final solution ?

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public