Effective December 3, NetApp adopts Microsoft’s Business-to-Customer (B2C) identity management to simplify and provide secure access to NetApp resources.
For accounts that did not pre-register (prior to Dec 3), access to your NetApp data may take up to 1 hour as your legacy NSS ID is synchronized to the new B2C identity.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

Setting Export Policy on Qtree

paeddy

Hi,

I'm currently creating Workflows, to create a CIFS Share and an NFS Export.

In these Workflows it also creates a new Qtree.

Now I want to set an Export Policy on this new Qtree.

I saw, that when you want to create a new volume you have the option to add an Export Policy, but when you create a Qtree this option is missing.

Is there any way to set an Export Policy on a Qtree in WFA?

 

Thanks for the help

Regards,

Simon

 

1 ACCEPTED SOLUTION

sinhaa

@paeddy

 

Simon,

 

I assume you are working with Clusterd DataONTAP and your WFA is on windows.

 

You need to create a new command for this.

 

1. Clone the existing "Create Qtree" command

2. Replace the code with the code as attached in txt file. I just added parameter Export Policy.

3. Press button "Discover Parameters"

4. Save the command and use it.

 

 

-----

 

This should fix the code part and it will work too. Only WFA dictionary table cm_storage.qtree doesn't have a row for Export Policy. Why? I don't know right now, its probably the designer choice. Or due to OCUM limitation.

 

This column in cm_storage.qtree can be helpful. This should give you advatnge of resource selection, reservation etc. So that would be complete solution for qtree with export policy.

If you want this, I can provide that too.

 

sinhaa 

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

View solution in original post

2 REPLIES 2

sinhaa

@paeddy

 

Simon,

 

I assume you are working with Clusterd DataONTAP and your WFA is on windows.

 

You need to create a new command for this.

 

1. Clone the existing "Create Qtree" command

2. Replace the code with the code as attached in txt file. I just added parameter Export Policy.

3. Press button "Discover Parameters"

4. Save the command and use it.

 

 

-----

 

This should fix the code part and it will work too. Only WFA dictionary table cm_storage.qtree doesn't have a row for Export Policy. Why? I don't know right now, its probably the designer choice. Or due to OCUM limitation.

 

This column in cm_storage.qtree can be helpful. This should give you advatnge of resource selection, reservation etc. So that would be complete solution for qtree with export policy.

If you want this, I can provide that too.

 

sinhaa 

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

View solution in original post

paeddy

sinhaa,

 

Thank you for your reply, this solved my problem!

I'm running WFA on Linux but that isn't a problem I just did the same thing as you in Perl.

 

Simon

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public