Active IQ Unified Manager Discussions

SnapMirror Reverse Resync



with which CLI-Task (or PowerShell-Task) may i accomplish this OnCommand System Manager process?

I tried this with a snapmirror quiesce and a snapmirror break, followed by a snapmirror resync (with reversed direction) but realized that the amount of snapmirror owned snapshots increases by each try (and i'm not able to cleanup because all snapmirror* snapshots do have a snapmirror application dependency).

Any ideas what's going wrong?




Hi Erich,


From what I understand, NetApp please correct me if I'm wrong, this is by design!

NetApp seem to have taken the direction of making it as hard as possible to mess things up... which, on occasions such as this, ends up with a mess.  There is a risk that deleting the snapmirror owned dependant snapshots will destroy the ability to resync so they don't allow it.

The snapshots can be deleted by going into advanced mode on the command line and deleting the snapshot with the -ignore-owners switch.

The CLI can reverse resync by using the resync command, and just entering the source and destinations in reverse.  I think the Powershell command follows the same approach, but it's been a while since I tried it in Powershell.


I personally find this lack of consistency with NetApp quite frustrating.  They have started a clean slate with cDoT and really should have taken the opportunity to standardise between the different methods of management, time better spent than decising to change between VSMs, SVMs, VMs etc...  Having to go into advanced mode to perform a day-to-day command (due to the reverse resync's not tidying up) is also not something I am comfortable with, it actually had the reverse effect from what is intended because when I was first struggling to get this sorted I ended up deleting the wrong snapshot causing a loss of data... good job that's what test systems are for Smiley Happy