Active IQ Unified Manager Discussions

System Manager 2.0 on 64 bit linux (again)

grahamk
6,149 Views

I understand that there might be an (unsupported) way to get system manager 2.0 to run on 64 bit linux.

If anyone has a procedure for this I'd sure appreciate seeing it - my customer is trying to hack the package with no luck - and since 64 bit linux is all they run it's hard to talk them out of trying this  - with everyone understanding that it is fully unsupported.

Past that - is this on the roadmap? Most people are running 64 bit these days - isn't it just a new compile?

Thanks,

Graham

1 ACCEPTED SOLUTION

karthikv
4,800 Views

The config file could have been corrupted due to which it is struck at loading systems

The System Manager config file is in User preference folder.

All the stored controller details will be lost when you Rename/Delete the "SystemManager.config" file present in the folder. So backup the config file before you do any modifications.

You will have to add controllers newly to the System Manager now.

Config File path -

In Win-7 say for Administrator:

C:\Users\Administrator\NetApp\SystemManager\

In Linux say for root:

/root/NetApp/SystemManager/

Can you please try the following and see if it works?

1. Backup the config file

2. Delete the config file

3. Start system manager

4. Add controllers

5. login and check whether it works

View solution in original post

13 REPLIES 13

misra
6,138 Views

Hi Graham,

Thanks for your comment.

64 bit LINUX support is on our Roadmap.

Thanks,

~Anjali

ralfaro01zero
6,138 Views

Hi grahamk,

I'm running System Manager 2.0 on Ubuntu 11.10 amd64, I've converted the .rpm package to a .deb package using "alien" (sudo apt-get install alien); I know it's not supported but It is working fine so far.

Cheers.

BrettEdelen
6,138 Views

thanks for the help. i got it installed, but now can't figure out how to launch it.

windows guy trying to work on ubuntu

ralfaro01zero
6,138 Views

There's a file called "system_manager.desktop" inside "/opt/NetApp/oncommand_system_manager/2.0", copy that file on your desktop, right click it, select "Properties", then mark the checkbox "Allow executing file as program". Every time you double-click it it will launch.

Cheers.

BrettEdelen
6,138 Views

you're awesome.

thank you

mmmjkaasg
6,138 Views

Has there been any update to this? When will we see a 64bit Linux version of Oncommand System Manager? I have a customer that needs it. Similar to Graham's situation above.

Thanks

-Mark

amritad
6,138 Views

Hi,

It is already available in our beta. Do try it out and let us know your feedback.

https://communities.netapp.com/groups/oncommand-system-manager-2x-build-1-beta-test

Regards

Amrita

CHAPEAUROUGE
6,138 Views

I could get it work like this:

http://ironman.darthgibus.net/?p=173

It worked fine for several weeks, then it is now stuck at "Loading systems", I don't really know why.

amritad
6,138 Views

Are you using the beta or 2.0.2?

REgards

Amrita

CHAPEAUROUGE
4,788 Views

I have done it with both. n 2.0.2, the line number is a bit lower than as said in the blog post, but same logic.

OnCommand worked peachy on a virgin system with 2.0. Then it stopped working -- stuck at loading system. I did it a few days ago with 2.0.2, but I guess I have files somewhere that trigger the same issue.

karthikv
4,801 Views

The config file could have been corrupted due to which it is struck at loading systems

The System Manager config file is in User preference folder.

All the stored controller details will be lost when you Rename/Delete the "SystemManager.config" file present in the folder. So backup the config file before you do any modifications.

You will have to add controllers newly to the System Manager now.

Config File path -

In Win-7 say for Administrator:

C:\Users\Administrator\NetApp\SystemManager\

In Linux say for root:

/root/NetApp/SystemManager/

Can you please try the following and see if it works?

1. Backup the config file

2. Delete the config file

3. Start system manager

4. Add controllers

5. login and check whether it works

CHAPEAUROUGE
4,788 Views

Hi,

Thanks for that.

So I did, readded my systems which got discovered fine. I entered my credentials, yet it throws this error:

"Connection timed out while trying to login to this system. This system may be down. Do you want to skip this system?"

I have no problem ssh'ing into the systems, so I don't know why it does that... It is possibly why it got stuck at "loading systems" before.

CHAPEAUROUGE
4,788 Views

Nevermind, it is because I added all discovered systems, which included IP such as 10.61.1.0. I just added the 2 heads, and it is working again. Thanks!

Public