Active IQ Unified Manager Discussions

Timeout with vCenter from WFA 2.1


I'm trying to add vcenter 5.0 as a datasource for WFA 2.1 at a customer environment.   I get a timeout (after the 600 seconds) with this error:

Command '$Uri = @($input)[0] ; E:\wfa\jboss\..\PoSH\profile.ps1;Invoke-WfaCommand -Script './vc_13814179598042044799709485333259.ps1 '' timed out

It works fine in my lab (of course).

The vcenter client works fine from the WFA server with the same credentials.    Any ideas?  Thanks.

-Alan Parker


Re: Timeout with vCenter from WFA 2.1



      You can try to connect to the VCenter directly by using the VMware PowerCLI installed on the WFA server. This will let us know if things work without WFA in picture.

1. Open a VMWare Power CLI console. It should be available as a Desktop short-cut on the WFA server. If it isn't open Windows  PowerCLI ISE or console and type the following:

PS C:\Users\Administrator> Add-PSSnapin VMware.VimAutomation.Core

PS C:\Users\Administrator>


PS C:\Users\Administrator> Connect-VIServer -Server -Protocol https -Port 443 -User Administrator -Password netapp

Name                           Port  User                         

----                           ----  ----                                   443   Administrator                

Use the same VCenter Hostname, Port as you have provided in VC Datasource.

3. Run a command to see it can fetch some data               

PS C:\Users\Administrator> Get-VM

Name                 PowerState Num CPUs Memory (MB)

----                 ---------- -------- -----------

14jan                PoweredOff 2        8192      

AD                   PoweredOn  1        4096      

Data ONTAP-v Inst... PoweredOff 1        1024      

Guarda-vm8           PoweredOn  4        12288

Let me know if this works fine, Our next step depends on the outcome of this result.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

View solution in original post

Re: Timeout with vCenter from WFA 2.1


Thanks.   This worked.   We increased the timeout setting in WFA and it works now.    Not sure why such a high timeout was necessary (1600, though we didn't try a lot of values between the default 600 and 1600).  

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums