If you missed the pre-registration for NetApp MS Azure AD B2C, the new login prompt will offer the option to register. Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

Unable to add c-mode system to WFA

dawho1621

Hey Everyone,

I'm hoping this will be an easy fix. I am trying to add credentials for my c-mode systems. When I enter the IP, username and passwd, it comes back with "failed to connect to controller, Incorrect credentials". I have check the creds countless times and i know they are valid. I've tried an account created specifically for this and also the admin account. no change in the resulting connection failure.

I have successfully added 7-mode systems to this WFA instance and they have not had any issues.

I have used wireshark to verify that the WFA server is sending/recieving network packets to the c-mode systems. There is certainly communication going on there, but it abruptly ends and then the connection fails. there are no firewalls between these systems.

Anyone have suggestions?

Thanks,

Mike

1 ACCEPTED SOLUTION

dawho1621

Yes, i did finally fix this issue with help from support, but it is unclear what the cause of the problem was.

I was using a password with special characters and we decided to create an alphanumeric password instead. Once we did that, it worked, and so i went back and changed the password back to one with special characters, and it continued to work. no explination why it did not work in the first place, but changing the password did something to fix it. (we had verified that we were using the correct password by testing the auth from the WFA server with powershell.)

View solution in original post

14 REPLIES 14

raj_shrivastava11

Hi Guys,

 

I have a same problem and i have tried all steps given in this post but it does not work.

 

I get same error "Failed to connect to cluster node: 153.112.47.109.
Incorrect credentials for 153.112.47.109."

 

Plus when i test the connectivity i get error "Ontap Host is unreachable"

 

We have verified the Ports are open and Telnet works. Plus i can also run Powershell commands from this same WFA Server to C-DOT cluster.

 

I can add 7-Mode Netapps but not any C-DOT systems.

 

Kindly help

 

Capture.PNG

dcornely1

Ignore Oncommand for now - as far as I can tell this doesn't have anything to do with OnCommand.  I'm running WFA v2 as well here and have successfully added the credentials for my CDOT 8.1.1 cluster.  I used:

-The cluster name (should be the admin vserver's name)

-The admin account and password

If you use this it should work, at least it does for me.

dawho1621

Yeah, i've been trying the cluster mgmt IP address and also the FQDN with the admin login. still getting a failure. I'm at a loss with this one...

dcornely1

Can you login to the cluster from your WFA server outside of WFA (i.e., using putty or something like it) with the same credentials?  This will at least confirm successful communication and login from the WFA server itself.

dawho1621

yes, i've confirmed that the WFA server can establish a connection via wireshark, and i've also logged into the cluster CLI with the same credentials on putty from the wfa server.

sinhaa

That's strange.

Okay let's see: 1. Do you have another 8.1 CDOT cluster to see if the credentials work for that or not using WFA ?

Instead of cluster management IP, you can even try one of the Node mgmt IPs. See if that works.

2. Does your Cluster credentials require a DOMAIN name in username e.g. DOMAIN\user1 ?

3. Is your WFA services running with a Local System account or a Username?

3.  Try this round about way :

      a. Delete the CDOT credentials which is failing.

      b. Add a new one with Match=Pattern , Type = ONTAP

      c. Give IP address of your cluster adding a * in the end. e.g. 10.54.4.100*

      d. Add credentials and save. Test button is disabled for Match=pattern.

      e. Test the connectivity selecting the type=ONTAP and ip 10.54.4.100.

       f. See if this works.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

sinhaa

Mike,

     Were you able to solve the problem you mentioned in the OP?

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

dawho1621

Yes, i did finally fix this issue with help from support, but it is unclear what the cause of the problem was.

I was using a password with special characters and we decided to create an alphanumeric password instead. Once we did that, it worked, and so i went back and changed the password back to one with special characters, and it continued to work. no explination why it did not work in the first place, but changing the password did something to fix it. (we had verified that we were using the correct password by testing the auth from the WFA server with powershell.)

View solution in original post

sinhaa

That's great.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

sinhaa

Can you post the exact failure message. Or add the screen-shot of the same. That can give some clue.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

dawho1621

This is what i get back from WFA. and here is what the log output from WFA looks like:

Incorrect credentials for 10.54.4.100., Cause: javax.ejb.EJBTransactionRolledbackException: Failed to connect to controller: 10.54.4.100.

Incorrect credentials for 10.54.4.100.}

2013-07-01 20:39:21,817 UTC ERROR [com.netapp.wfa.ui.LogServiceImpl] (http-0.0.0.0-80-4) [unknown] com.netapp.wfa.ui.app.main.ErrorController - Failed to connect to controller: 10.54.4.100.

Incorrect credentials for 10.54.4.100.

2013-07-01 20:39:21,818 UTC ERROR [com.netapp.wfa.ui.LogServiceImpl] (http-0.0.0.0-80-4) [unknown] com.netapp.wfa.ui.app.main.ErrorController - details:

fault code: WFA.CommandExecution

fault String: Failed to connect to controller: 10.54.4.100.

Incorrect credentials for 10.54.4.100.

fault Details: - destination: ExecutionFacadeImpl

- method: public abstract void com.netapp.wfa.ui.ExecutionFacade.validateCredential(com.netapp.wfa.command.model.CommandCredential)

- exception: javax.ejb.EJBException: WfaException{Message: Failed to connect to controller: 10.54.4.100.

The thing is, i know that the creds are correct. i've triple checked them.

dawho1621

Also, versions...

WFA: 2.0.1.23.8

DOT c-mode: 8.1.2

UM server: 5.1.0.15008 (5.1)

abhit

Is this a 5.1 C-mode system to which you want to connect to?

If yes, did you run the wfa_ocsetup.exe to create the username/password on DFM?

Regards

Abhi

dawho1621

Yes i did complete the wfa_oc... setup, and i was able to connect to the UM server without issue. it is just when i try to add the controller credentials that i'm am having issues.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public