Active IQ Unified Manager Discussions

Unable to enumerate Vservers in wfa on 4 node cluster

olson
2,242 Views

Hello,

     I am currently troubleshooting a problem where I am unable to enumerate any Vservers from wfa. I have verified the dfm host shows all of the vservers however at this time I am unable to retrive non node/admin vservers from the wfa database. What log files should I be looking to see why this is not working?

this is the current database

SELECT * FROM cm_storage.vserver;

'192', '189', NULL, 'cluster001-n01', 'node', 'e8727e01-264d-11b2-89ee-00a098164a94', NULL, NULL, NULL, NULL, NULL, '0', '0', '0', '0', '0', '0', '0', '0', NULL, '0'

'193', '189', NULL, 'cluster001-n02', 'node', 'e8c17940-3a6f-11e2-a7b0-00a09816302c', NULL, NULL, NULL, NULL, NULL, '0', '0', '0', '0', '0', '0', '0', '0', NULL, '0'

'194', '189', NULL, 'cluster001-n03', 'node', '45fd07d9-4857-11e2-b50d-d1bbd888d5cd', NULL, NULL, NULL, NULL, NULL, '0', '0', '0', '0', '0', '0', '0', '0', NULL, '0'

'195', '189', NULL, 'cluster001-n04', 'node', 'e86caa8a-4857-11e2-9368-d54bb32e0cb0', NULL, NULL, NULL, NULL, NULL, '0', '0', '0', '0', '0', '0', '0', '0', NULL, '0'

'196', '189', NULL, 'cluster001.domain.loc', 'admin', '65ba14b5-272b-11b2-89ee-00a098164a94', NULL, NULL, NULL, NULL, NULL, '0', '0', '0', '0', '0', '0', '0', '0', NULL, '0'

'197', '190', NULL, 'cluster002-n01', 'node', '092ba286-4893-11e2-ad4a-f59d0f8220a3', NULL, NULL, NULL, NULL, NULL, '0', '0', '0', '0', '0', '0', '0', '0', NULL, '0'

'198', '190', NULL, 'cluster002.domain.loc', 'admin', '8ba786a5-4918-11e2-89b3-123478563412', NULL, NULL, NULL, NULL, NULL, '0', '0', '0', '0', '0', '0', '0', '0', NULL, '0'

dfm vserver list

ID   Virtual Server            Cluster                             Deleted

---- ------------------------- ----------------------------------- -------

21270 vs01-a-qa              cluster001.domain.loc                        No

21274 vs01_vmware               cluster001.domain.loc                        No

21280 vs02-a-qa              cluster002.domain.loc                        No

21269 vs02_sql_pr               cluster001.domain.loc                        No

21279 vs02_sql_pr_dr            cluster002.domain.loc                        No

21271 vs03_general_pr           cluster001.domain.loc                        No

21265 vs05_de             cluster001.domain.loc                        No

21266 vs07_de              cluster001.domain.loc                        No

21273 vs09_de             cluster001.domain.loc                        No

21272 vs11_de             cluster001.domain.loc                        No

21281 vs11_dr             cluster002.domain.loc                        No

21268 vs13_de             cluster001.domain.loc                        No

21282 vs13_dr             cluster002.domain.loc                        No

21264 vs22_cifs_nfs       cluster001.domain.loc                        No

21267 vs99_old_vmware           cluster001.domain.loc                        No

Without the server data I am unable to use finders for vservers. Any help would greatly be appreciated.

5 REPLIES 5

yaronh
2,242 Views

Can you elaborate? I see that the cache has the Vservers - What do you mean by enumerate?

What are you trying to do?

Yaron

olson
2,242 Views

Hi Yaron,

               I just setting up a wfa for clustered ontap. I am able to enumerate the clusters drop down boxes however, I am not seeing volumes or Vservers in any of the drop down boxes.

John

yaronh
2,242 Views

John,

Where? Which flow? One of the samples?

How did you enumerate?

Yaron

olson
2,242 Views

Yaron,

          The sample workflow for create a cmode volume enumerates the clusters but does not show any vservers. Where is the finder pulling this information from? I assumed the cm_storage.vserver however that table is incomplete.

John


tanzim
2,242 Views

Hi Olson,

Is this issue resolved? Do you need any further assistance?

Regards,

Tanzim

Public