Active IQ Unified Manager Discussions

Unable to export workflow


When I try to export the workflow It gives error like below snapshot. What should be the problem with WFA. I tried restarting server but still it throws the same error




Re: Unable to export workflow


Which version of WFA are you using ? 

As a workaround, you can obtain the exported dar file from location: C:\Program Files\NetApp\WFA\jboss\standalone\deployments\download.war\


View solution in original post

Re: Unable to export workflow


Version :


Build Number :3511759


Export was working 2 days back. Yesterday I tried to exporting workflow it was not working. The alternative which you provided , I got .dar file from there. Thanks


Re: Unable to export workflow


I ran into this problem with WFA


Like the original poster, downloads were working at some point, and a few months ago just seemed to stop working. I know the backups are being stored in C:\Program Files\NetApp\WFA\jboss\standalone\deployments\download.war since I see the zip files there, but am concerned why the UI is broken. That directory has a WEB-INF directory as well, but I don't know enough about those XML files.

Re: Unable to export workflow


With the help of support, I was able to find a bug report that outlined the problem. The workaround is half-baked and needs a rewrite. Does not seem to be a root cause identified yet.


The README file in the deployments folder was the key to figuring this out, since I have next to zero knowledge of JBoss.


In the deployments JBoss root folder, you may see some files that end in either .undeployed or .failed, which are most likely the root cause of why you're getting these 404 errors. For me, the problem was these files:





Inside of each of the download.war, log.war, and log-download.war folders, I confirmed there was an error and WEB-INF folder. If you don't have those in there, copy them from somewhere like help.war.


Remove the .undeployed files, and replace them with empty .dodeploy files:





This should trigger JBOSS to read these files and then deploy these folders. After a couple seconds, these .dodeploy files should disappear, and you should see new files in the deployments folder with .deployed suffices, which means you should be good to go and your 404 errors should be gone. Worked for me!



Re: Unable to export workflow



Exact the right solution for the same problem in my WFA 4.2 GA installation.

Many thanks!



2021 NetApp Partner Experience Survey
PES Banner
All Community Forums