Effective December 3, NetApp adopts Microsoft’s Business-to-Customer (B2C) identity management to simplify and provide secure access to NetApp resources.
For accounts that did not pre-register (prior to Dec 3), access to your NetApp data may take up to 1 hour as your legacy NSS ID is synchronized to the new B2C identity.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

Upgraded WFA 4.0 to 4.2 receiving SOAP and REST SSL errors

ninja

After upgrading WFA and migrating the database to a new server we aren't able to do rest or soap over powershell. Error is related to SSL.

 

 

 

Error received when attempting SOAP

 

New-WebServiceProxy : The request was aborted: Could not create SSL/TLS secure channel.

 

 

Error received when attempting REST

 

Exception calling "GetResponse" with "0" argument(s): "The request was aborted: Could not create SSL/TLS secure channel."

5 REPLIES 5

abhit

Please contact customer support and submit a ticket.

 

Regards,

Abhi

ninja

Had no idea NetApp supported WFA under the standard case creation process.

SHYAMVOLVO

Hi @ninja  is the issue what you are facing solved ?

I am also having similar error when trying to connect to WFA 4.2   ....   with WFA 4.1  its works fine .. 

 

is it possible for your to post the code which you are using to connect to WFA using REST over powershell ?   . 

 

 

Thanks 

Shyam

ninja

I don't have a fix yet. My NetApp case is still open. I will post the fix once I have it.

SHYAMVOLVO

@ninja

 

you need to enable TLS 1.1 and TLS 1.2 on your windows server and also enable the same protocol on WFA .  I tried it and its works fine for me .

 

try downloading   "IISCrypto.exe "   from  https://www.nartac.com/Products/IISCrypto    ..  by this is pretty easy to enable it . 

 

then enable the same protocol in WFA  by 

 

clip_image001.png

 

 

 

Then restart your windows server .. 

 

use   below code in your script ensure that you are using TLS 1.2  . 

 

 

[Net.ServicePointManager]::SecurityProtocol = [Net.SecurityProtocolType]::Tls12

 

 

 

Thanks 

Shyam

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public