Active IQ Unified Manager Discussions

WFA 3.1P2 upgrade attempt - Could not take backup of WFA DB


I am unable to apply the WFA 3.1P2 upgrade to an existing Win2012R2 WFA 3.1P1 system. I keep getting the below error no matter which user/pswd I enter for backing up. System has plenty of space (60GB, 35GB free). 





BTW -- When the install wizard asks for a user/pswd for backup is it asking for: A WFA local user (type=admin -or- type=backup)? A Win2012 local or AD user, admininstrator? Is it using this account or creating this account? Wording is vague so I've tried most all of the above.


Also, as the install finishes it presents the attached logfile for viewing which gives me no clues. Just the same error - an extract:

----- snippet -----

InstallShield 12:01:36: Registering Msi Server...
InstallShield 12:01:36: Invoking script function wfaTakeBackup
Custom Install Log INFORMATION:
Successfullt set regustry root key to HKEY_LOCAL_MACHINE.
Custom Install Log INFORMATION:
Install dir during upgrade INSTALLDIR=C:\Program Files\NetApp\WFA\
Custom Install Log INFORMATION:
szBackupDir=C:\Program Files\NetApp\
Custom Install Log INFORMATION:
Params to create Dir=C:\Program Files\NetApp\WFA-Backups
Custom Install Log ERROR: UPGRADE: Could not take backup of WFA DB during upgrade. Aborting upgrade.
InstallShield 12:07:44: Setup aborted
InstallShield 12:07:44: CallScriptFunctionFromMsiCA() ends, result 0x642
MSI (s) (DC!34) [12:07:44:338]: Leaked MSIHANDLE (559) of type 790531 for thread 2100





wfa-31P2 upg attempt.png



Re: WFA 3.1P2 upgrade attempt - Could not take backup of WFA DB


try this and see it helps?


Backup and export operations fail when the JBOSS server is unable to deploy the 'download.war' service that is used to perform backup and export of files from
the OnCommand Workflow Automation server.


The default location of WFA installation is: C:\Program Files\NetApp\WFA\jboss\standalone\deployments.
Perform the following from <WFA-INSTALLED>\jboss\standalone\deployments folder.

1. Copy WEB-INF and error folders from help.war to download.war.
2. Rename download.war.failed to download.war.dodeploy.

View solution in original post

Re: WFA 3.1P2 upgrade attempt - Could not take backup of WFA DB


Thanks. That was exactly my problem. I can't believe that didn't occur to me since that issue has hit me bedore. 🙂

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums