Active IQ Unified Manager Discussions

WFA Commands to add Cluster to OCUM and WFA

joshuag
4,620 Views

I'm looking for WFA commands that will add a newly installed cluster to OCUM and add the WFA credentials for that cluster

10 REPLIES 10

abhit
4,563 Views

From the WFA command, you can call a REST API to add the cluster credentials to WFA.

See http://localhost/rest/docs/resource_CredentialsResource.html#path__credentials.html.

OCUM side, need to check if any API or CLI exists.

 

Regards,

Abhi

joshuag
4,551 Views

abhit
4,502 Views

I am able to access it in my local install.

Which version of WFA are you using?

 

Please click on the highlighted link in the image.

Help->Support Links -->Rest API help.

 

Regards

Abhi

 

joshuag
4,498 Views

I see.  Thanks all who replied.  That would be a nice feature to add. The use case is I'm installing and configuring a cluster via WFA. So, after installing the cluster via WFA, A manual step needs to be added to add the cluster to OCUM prior to proceeding with the configuration.

sinhaa
4,462 Views

@joshuag

 

The command you need has been emailed to you.

 

 

sinhaa

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

joshuag
4,432 Views

Have not received command. 

 

There is a "datasource-add" ZAPI element that allows you to add the Cluster to OCUM.  I modified the "Refresh Cluster monitoring on an OCUM 6X" command to add this element along wit the child elements. 

The workflow job fails with a "Failed invoking API - Request Timout". However, the job still runs in the backgroud and completes sucessfully in OCUM. The job takes about 15min to complete on my OCUM server.  I tried adding a wait command by simply appending existing code with this line and adjusting the wait time.

 

Set-WfaCommandProgress -Total 1 -Current 1 -ProgressPercentage 100

 

Still no luck with preventing the WFA command from a timeout. 

sinhaa
4,391 Views

The last mail send failed due to unknown reasons. Sent it again.

 

sinhaa

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

msaravan
4,520 Views

If you want to add a cluster to OCUM directly, OCUM doesn't have any external API/CLI for that.  You need to use OCUM GUI only.

 

At present, I suggest you to use the solution provided by Abhit.

 

Regards,

Saravanan

msaravan
4,352 Views

I would like to give an update on the interfaces that are available for the users to add clusters to OCUM:

 

1. GUI - Its known to everyone.

2. CLI - We have a um cli called "um datasource add ..", and using this you can add a cluster to OCUM. This CLI is exposed only for RHEL and Windows. Since the vApp is a closed box, this is not applicable at the moment.

 

Regards,

Saravanan

joshuag
3,065 Views
Thanks for the explanation. That explains why I can't connect to my OCUM vAPP box via http/https. However, there is a work around. You must add OCUM credentials to WFA. Then you can use the OCUM credentials to connect and run the datasource-add command. I have this part working in PoSh. My new problem is getting the command to wait for completion. Trying to find a way to track the progress so I can wait for completion.
Public