Active IQ Unified Manager Discussions

WFA Exception with waitForCompletion



I experience following exception when launching waitForCompletion REST API after executeWorkflow

WFA build 3670333



2016-07-05 09:13:45,002 WARNING [org.apache.cxf.phase.PhaseInterceptorChain] (default task-35) Interceptor for {}WorkflowService_rpcService#{}waitForCompletion has thrown exception, unwinding now: org.apache.cxf.interceptor.Fault: Could not send Message.


That works fine in 2879153


Any help appreciated.





Its a WFA SOAP api, not REST


I tried waitforcompletion on wfa 4.0 as you mentioned and it worked for me. 


Now to debug this, can you tell me what is your client being used to call this API? Is it a powershell code? which version of powershell do you use. Can you share you code snippet. You can PM me if want.



The thing is WFA4.0 has upgraded some of its building block infrastructure  sw. And we had encountered an error previously. So , let see







If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.




Have you been able to resolve this? 


I see this as  an issue with your Client ( python suds module ) with WFA4.0 Jboss 8.2.0. Not 100% certain but in the past I had come acoss an issue with Powershell and Jboss7.1 and that was showing similar behaviour in terms of not working with the latest WFA but working fine with the older one ( having older Jboss version)


I've tried the said APIS with Powershell and it works all fine. Also tried with other SOAP UI clients and they also work fine.



PS WSMan:\> $proxy = New-WebServiceProxy -Uri -Credential $cd


PS WSMan:\> $proxy.executeWorkflow(117, ("Country=Sweden", "Sec=30"))

PS WSMan:\> $proxy.waitForCompletion(2117)

comment :
endTime : Jul 27, 2016 4:41:00 PM
errorMessage :
jobStatus1 : COMPLETED
jobType : Workflow Execution - Workflow to Print a Footballer Name - delete 2
plannedExecutionTime : Jul 27, 2016 4:40:15 PM
returnParameter : {Name}
scheduleType : Immediate
startTime : Jul 27, 2016 4:40:21 PM
userInputValue : {Country, Sec}
workflowExecutionProgress : Microsoft.PowerShell.Commands.NewWebserviceProxy.AutogeneratedTypes.WebServiceProxy3fa_ws_WorkflowService_rpc_wsdl.workfl



PS WSMan:\>





I've not worked extensively with python, so atm I'll not be able to suggest anything to solve this. But I'll look into it for sure.


If you have found some resolution, kindly post it here.



If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.




The problem seems to be fixed now. No idea what appenned.

Probably it was relayed to a python version and modules.


Thank you for your support



NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner