Active IQ Unified Manager Discussions

WFA - Problem with vCenter 6.5 Data sources




Our problems : 

Could not discover vCenter 6.5 and vCenter 6.0 with the existing data source (it's in the compatibility matrix, so shouldn't we be able to discover it natively ?)

Could not import the NetApp data source ( to a 5.0 environment


The environment : 

- WFA 5.0 on Windows

- vCenter 6.5 and vCenter 6.0


Some context : 


We upgraded to 5.0 lately and restored our database from 4.1 so that we keep all our workflows and configuration. 


We tried to discover some 6.0 and 6.5 vCenters but the native vc datasource couldn't do the job (only supporting until vCenter 5.5 so the loading of the snapping wasn't correct anymore, some info caused the data collection to crash on the scsi runtimename...)


We then added a custom data source type from the netapp automation store ( We had to copy the script code as we couldn't import it in our environment. 


The data source still didn't work (invalid credentials because it couldn't find the correct credential for our host, while we had the exact same hostname between the credential menu and the data source). We had to change the following code line : 


$connectionInfo["credentials"] =  Get-WfaCredentials


By this one (to force wfa to get the correct hostname credentials) : 


$connectionInfo["credentials"] =  $(Get-WfaCredentials -Hostname $($connectionInfo["host"]))


I hope our process will be useful for other users as the acquisition worked once we did all that. 


Is it planned to add a native support for vCenter 6.0 and 6.5 to WFA ? And are the steps we had to do "normal" here ? Because we shouldn't have to 'recode' some of the scripts from NetApp. 





@LFueyo  Let us know if you are still looking for help, I will help you connect to an expert who can help you answer your queries.