Community maintenance is complete. Thank you for your patience!

Active IQ Unified Manager Discussions

how can we change snapshot policy on an existing volume

stephen2

Anyone know how to do this? I don't see a -snapshotpolicy field in update-ncvol

I tried using a template, but the object returned does not have an volumesnapshotattributes object.

I also tried $cmd2 = "volume modify -vserver $svm -volume $volname -snapshot-policy none -confirm $false"
 invoke-ncssh $cmd2

 

I need to change snapshot policies on a volume, but I can't figure this one out

2 REPLIES 2

Mr_Flibble

Hello Stephen,

 

I'm pretty sure I saw something written by Steven Beam somewhere which I used, but can't remember where.

Anyway, this is an extract of one of my WFA commands which should indicate how it works:

 

$VOLquery = Get-NcVol -Template
Initialize-NcObjectProperty -Object $VOLquery -Name VolumeIdAttributes

$VOLquery.VolumeIdAttributes.OwningVserverName = $VserverName

 

$VOLattrs = Get-NcVol -Template
Initialize-NcObjectProperty -Object $VOLattrs -Name VolumeSnapshotAttributes

 

$VOLquery.VolumeIdAttributes.Name = $VolName
$VOLattrs.VolumeSnapshotAttributes.SnapshotPolicy = $SnapshotPolicy


Update-NcVol -Query $VOLquery -Attributes $VOLattrs

 

Hope it helps.

 

Cheers!

stephen2

Thanks - just what I needed

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public