Active IQ Unified Manager Discussions

oci 7.3.13 java not found wildfly - STOP encountered

Is here someone who can assist me with OCI (7.3.13) please?
There was another application installed onto the OCI server, which have (seems so) broken the SanScreen Java references.
All other versions of Java was removed, and ONLY .311 was kept, afterwards, as that is referenced in the
"C:\Program Files\SANscreen\java64\lib\" path.
This has not fixed the issue, and, according to the logs, wildfly fails to fly (load) as it cannot verify java. 
Java Info from the above path: javafx.runtime.version=8.0.311 
Java Installation folder: 
"C:\Program Files\SANscreen\java64\lib\"
"C:\Program Files\SANscreen\java\lib\"
The Java variables are also set to:
"C:\Program Files\Java\jre1.8.0_311"


When you install OCI, you are not installing Java per se, as a registered application that the Windows Add/Remove Programs aka "Windows Installer" infrastructure knows about.


OCI lays out its Java versions on disk, in its folder structure, but we do not set system environmental variables like JAVA_HOME, etc


That said, if someone were to install Java on the OCI server to run the OCI java client, you would have Windows Installer see a Java install. I honestly forget if a Java Runtime Environment (JRE) installation sets JAVA_HOME, or if that only occurs by default with a JDK


A first cut at triage: drop to a cmd prompt:


C:\Program Files\SANscreen\java64\bin>java -version


Does that run cleanly? I don't know offhand what JRE is in 7.3.13, on 7.3.14:


java version "1.8.0_333"
Java(TM) SE Runtime Environment (build 1.8.0_333-b02)
Java HotSpot(TM) 64-Bit Server VM (build 25.333-b02, mixed mode)


If you don't see something similar, that would certainly explain why Wildfly cannot start.


I would recommend installing 7.3.13 on a temporary VM - if your Java is in fact broken, you could simply move your current ..\sanscreen\Java64 to a backup location, and copy in that folder structure from the temporary VM.


Then, run "java -version" in that same path - it should execute. At this point, you should have a sane JRE in the right place. Try bringing up the services.


Thanks for the feedback.

I ran the command and it gives the following error:


c:\Program Files\SANscreen\java64\bin>java-version
'java-version' is not recognized as an internal or external command,
operable program or batch file.


The problem however is that the Customer have not renewed their OCI subscription, and I don't have access to the software any longer. They are investigating to go to CI however, but that can still take a few months...


Busy changing things.


Okay - I have installed java on a separate machine and copied the software as mentioned in the document above.

I get the following results after doing that:

C:\Program Files\SANscreen\Java64\bin>java -version
java version "1.8.0_311"
Java(TM) SE Runtime Environment (build 1.8.0_311-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.311-b11, mixed mode)

"C:\Program Files\SANscreen\java64\lib\" = javafx.runtime.version=8.0.311 and

= wildfly started BUT i still get the error 404. Not Found page.

The System Variable "JAVA_HOME" is now set to "C:\Program Files\SANscreen\Java64\bin"

and the User Variable "JAVA_HOME" is set to C:\Program Files\SANscreen\Java64\bin

In the meantime I found the following lines in the log file2024-04-02 18:47:39,233 INFO [MSC service thread 1-7] deployment ( - WFLYSRV0028: Stopped deployment compose.war (runtime-name: compose.war) in 92710ms
2024-04-02 18:48:09,827 INFO [MSC service thread 1-1] deployment ( - WFLYSRV0028: Stopped deployment rest.war (runtime-name: rest.war) in 153533ms

I also found this document referencing both the .war stopped deployment and the error 404 message.
, which I tried to fix, but the file extensions returned to failed.

Any suggestions?