Effective December 3, NetApp adopts Microsoft’s Business-to-Customer (B2C) identity management to simplify and provide secure access to NetApp resources.
For accounts that did not pre-register (prior to Dec 3), access to your NetApp data may take up to 1 hour as your legacy NSS ID is synchronized to the new B2C identity.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

"Clone Volume" command fails after upgrading to WFA 4.1.0.0.1RC1

lornedornak

After upgrading to WFA 4.1.0.0.1RC1, we receive the following when executing the "Clone Volume" command.

 

10:37:44.436 INFO [Clone volume] ### Command 'Clone volume' in 'POWER_SHELL' ###

10:37:46.608 INFO [Clone volume] Get-WfaCredentials -Host clus1

10:37:46.639 INFO [Clone volume] Credentials successfully provided for 'clus1'

10:37:46.671 INFO [Clone volume] Connect-Controller -Type CLUSTER -Name clus1 -Credential System.Management.Automation.PSCredential -Vserver

10:37:46.749 INFO [Clone volume] Connect-NcController (with credentials) -Name clus1 -Timeout 60000 -ErrorAction Stop

10:37:49.030 INFO [Clone volume] Connected to cluster node

10:37:49.921 INFO [Clone volume] Create a clone for Volume 'vol1' , named 'vol2' on Storage Virtual Machine 'clus1v01'

10:37:49.968 ERROR [Clone volume]

| This cmdlet must be directed to a data vserver. You are currently connected |

| to the cluster admin vserver. See the Toolkit web docs (Show-NcHelp) or online |

| help (Get-Help Connect-NcController -Examples) to learn more about directing |

| Toolkit cmdlets to a cluster or data vserver as required by Data ONTAP. |

10:37:50.077 ERROR [Clone volume] Command failed for Workflow 'Workflow' with error :

| This cmdlet must be directed to a data vserver. You are currently connected |

| to the cluster admin vserver. See the Toolkit web docs (Show-NcHelp) or online |

| help (Get-Help Connect-NcController -Examples) to learn more about directing |

| Toolkit cmdlets to a cluster or data vserver as required by Data ONTAP. |

10:37:50.077 INFO [Clone volume] ***** Workflow Execution Failed *****

 

In the above output, the -Vserver value is missing from the following:

10:37:46.671 INFO [Clone volume] Connect-Controller -Type CLUSTER -Name clus1 -Credential System.Management.Automation.PSCredential -Vserver

 

To workaround, I modified the following code line in the "Clone Volume" command as follows:

 

Before:

Connect-WfaCluster -Node $Cluster 

 

After:

Connect-WfaCluster -Node $Cluster -Vserver $VserverName

 

Of course, this is not ideal, because it's still broken if you use $ParentVserver

8 REPLIES 8

jauling_chou

This bug is also present in WFA 4.0.0.0.0 build 3858982. Since we dont use parent vserver, the workaround is fine for us. Adding the "-Vserver $VserverName" in the PowerShell code was necessary for us to talk to ONTAP 8.2 and 8.3 clusters.

James_Castro

FYI to others...we use WFA4.0, OCUM 7.1, CDOT 8.2 and 8.3.  Had to modify the 'Clone Volume' command and add the [-Vserver $VserverName] switch to the powershell code (highlighted in the screenshot below).  Since you can't modify a signed command you have to  hit "save as" and rename it.  You'll then need to replace the command in your workflow.  I'm hoping to test on 9.1 soon.

 

example1.png

Cmdlet used in the Clone Volume command is acting in the controller contest, and when we pass junction path as a parameter, it should work in the Vserver contest, presently which command is not able to handle .

 

The fact, the ZAPI/Cmdlet used in the Clone Volume command can act on both the contexts, vserver as well as cluster(controller).

This command has been used in the SVM_DR pack as well where that should work on cluster context when user will pass the parent vserver name ($ParentVserver).

 

We have already fixed this issue and it’s in review, it will be part of 1.2.2 pack.

sinhaa

@James_Castro @jauling_chou @lornedornak

 

 

This bug appeared due to change in DataONTAP PSTK module which WFA powershell commands use. This is being fixed and will be available on NetApp Automation Store very soon.

 

You would need to download and import the latest cdot pack. 

 

I'l update this post as soon as its done.

 

till then your inconvenience is regretted.

 

 

sinhaa

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

sinhaa

@lornedornak

 

I tried the command with the mandatory parameters on ONTAP 8.4.0 and it worked for me.

 

Are you still getting the error?

 

To debug further, please provide the following info.

 

1. Ontap version

2. Screen shot of the command Test. I want to see which all parameters are you using.

 

 

sinhaa

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

lornedornak

@sinhaa

 

Ontap Version:  8.3.2p5

 

Screen shot:

 snip_20170117144913.png

sinhaa

@lornedornak

 

This is being looked into. I'll update you on this.

 

 

sinhaa

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

James_Castro

any updates yet?

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public