Effective December 3, NetApp adopts Microsoft’s Business-to-Customer (B2C) identity management to simplify and provide secure access to NetApp resources.
For accounts that did not pre-register (prior to Dec 3), access to your NetApp data may take up to 1 hour as your legacy NSS ID is synchronized to the new B2C identity.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

using an aggregate list from a sql query in a volume command


I have a workflow that I want to change from a filter/finder to a sql query and so that the person can choose from a list of aggregates to place a volume in.  I found sample sql queries for doing just that in the community and I tweaked it a little to represent what I wanted and that works fine when I run the workflow.  However, in the volume command I am not sure what to do.  I put in a variable name called $AggregateName in the aggregate field and a corresponding return parameter (volume.aggregate.name) in setup and does not work.   I ran the workflow in preview and I get this error.

Found value '$AggregateName' - expected object reference of type 'cm_storage.Aggregate'

At command 'Research -- Create volume', tab 'Volume', variable 'volume', property 'aggregate'

How do I get the information from the sql query and the aggregate selected in workflow to the aggregate property in the volume command.

The volume command has cm.storage.volume as the type and the attribute is aggregate.name

I cloned the Create volume certified command and called it Research -- Create volume.



The Parameter AggregateName in the command is an object reference [ Notice a Blue 'R' in front of the AggregateName in workflow]  and hence you can't declare a variable $AggregateName for it.

You need to modify the  Parameter "Type" and "Attribute" for the AggregateName parameter in your cloned command.

Set: Type: cm_storage.aggregate

Attribute: name

Object: AggregateName

Save it. Now it should be fine to used $AggregateName and select query for User Input.

See below.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.


I get the same type of error after changing the type.

Found value '$AggregateName' - expected object reference of type 'cm_storage.Aggregate'

At command 'Research -- Create volume - testing', tab 'Volume', variable 'volume1', property 'aggregate'

in the Details I see that it it looked like it put the name of the aggregate in the variable.  So


Kindly export and  attach your workflow, sceen-caps are not helping much. I've verified with the change and for me it works fine. If you don't want to share your workflow here, send the .dar file to my mail id: sinhaa at netapp dot com


If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.



I created a simple workflow for "Create

You can look for AggrName.

Let me know if you need further clarifications.

The file is named as *.dar.txt.

Please rename it to *.dar and import it.




Been away for a bit...thanks for working this.

Thanks but the dar you attached is at not available to me  I am at

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner