Data Backup and Recovery Discussions

SMO rollingupgrade to 3.2 fails


Hi all

I'm trying to do a rollingupgrade of SMO for Windows from version 3.0.3 to version 3.2.  I've installed the software on the host, but when I run the rolling upgrade command to upgrade it's entries in the repositories I get the following error:

C:\Program Files\NetApp\SnapManager for Oracle\bin>smo repository rollingupgrade -repository -dbname oemdb -host rephost -login -username SMO -port 1521 -upgradehost -force


Once this operation has begun, you will not be able to cancel it.  Are you sure you wish to proceed with the repository rolling upgrade (Y/N)? y

[ INFO] SMO-09283: Existing old repository version "64"

[ERROR] SMO-09234: Following hosts does not exist in the old repository.

[ERROR] SMO-13032: Cannot perform operation: Repository Rolling Upgrade.  Root cause: SMO-09234: Following hosts does not exist in the old repository.

[ INFO] SMO-13039: Successfully aborted operation: Repository Rolling Upgrade

[ERROR] SMO-13048: Repository Rolling Upgrade Operation Status: FAILED

[ INFO] SMO-13049: Elapsed Time: 0:00:01.797

Operation Id [N683a59e9153692dd81900789cf3f6dc8] failed. Error: Following hosts does not exist in the old repository.

But if I query the repository, the host is there:

C:\Program Files\NetApp\SnapManager for Oracle\bin>smo repository show -repository -port 1521 -dbname oemdb -host rephost -login -username SMO

Repository Definition:

  User Name: SMO

  Host Name: rephost

  Database Name: oemdb

  Database Port: 1521

  Version: 64

Hosts that have run operations using this repository: 13



Profiles defined in this repository: 24





Incomplete Operations: 0

I've tried every combo of upper case, lower case, FQDN, short name, IP address etc. but with no luck.  This is the first server we've tried this on, but until we get this one working we won't be doing it on any others as we don't want to break the currently working SMO environment.

Anyone got any ideas?





Hello Chris,

Can you please send the logs for the above operation.




Meanwhile Chris, Can you also try to run the above command with hostname specified within double quotes.

smo repository rollingupgrade -repository -dbname oemdb -host rephost -login -username SMO -port 1521 -upgradehost ""




I've re-run the command with the host name in double quotes, but it has the same error.  I'll get the logs now.

I also have a case open with support.

I've attached the log.  Basically, looking at the log it matches up the host name but then says it can't find any profiles which match the host name.  However, the profiles are all there with the correct hostnames.



It has 3 interfaces,, and there are no profiles listed when queried, that's the reason it says that the host dosen't exist in the repository. If we can get the repository show command log file, it can be of some help to debug.



NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner