Data Backup and Recovery

Can't see any disks in SnapDrive.



I have installed the disks(3st) with iscsi initiator. But when i installed the SnapDrive software i can't see the disks in the SnapDrive application.




I just reinstalled the snapdrive and now it works just fine.


View solution in original post



Need a little bit more information to help.  What OS are you using and is this a new filer or iSCSI LUNs are working fine on other hosts, etc.




Os: ms Windows server 2008r2 x 64

This à new iscsi lun, i have orter witch is working. This server is not à member of the domain.




How did you setup authentication of snapdrive with the filer? I assume HTTP/HTTPS, because RPC will not work.


Iám using RPC i will change and run a test.


Have the LUNs ever been mapped to the server? If not....

Check the following:

- On the server ensure that the iSCSI service is running and can see the NetApp filer as a target; test using ping if required.

- In System Manager ensure that the LUN which is to be mounted to the server has the correct ISCSI Initiator mapping. The server you are connecting to should have its iSCSI name listed.

If both above are correct in the iSCSI initiator choose to connect to the NetApp target, if this is showing as connected then the iSCSI is mapped but the drives unformatted.

"Right click my computer > Manage > Disk management."

You should see the unformatted drives ready to use on the server.

As for the SnapDrive application, was it installed with an account that has Local Administrator credentials on the server, also have you set the connection credentials for connecting to the filer?     


Hi Jason

Yes the LUN´s have been mapped to the server. I can see the iscasi disks in file explorer, but i can´t see the disks in SnapDrive. I have installed the SnapDrive application with local admin account.



Ah well thats good! So all is working on the comms side, its just a config issue with SnapDrive.

Can you see the filer in the SnapDrive? If so, what you may have to do is disconnect the iSCSI drives from the server within Windows Explorer and use the SnapDrive "connect to disk" feature to establish the connection. Once this is done, it should allow you to select the volume and then the LUN where the iSCSI drive has been created. The next screen will be drive mount points and drive letters.

Just run through the wizard until complete... good luck!!

At the moment SnapDrive is unaware of the realtionship between the filer and the Server as it has been created manually and not through SnapDrive.

NB. Also just check the SnapDrive services are running.


Also be aware that SnapDrive "prefers" to create any LUNs that you want it to manage.

If you are connecting previously created LUNs then there is a process you need to follow in the Setup and Admin guide for SnapDrive so these will work correctly in future.


I've seen issues with anti virus software in the past. In my particular case, it was Trend Micro. After system admin did an upgrade to OfficeScan Client version 10.5, Snapdrive was not able anymore to connect to the disks. Only message "Establishing connection" was shown. After disabling "OfficeScan NT Proxy Service" and restarting the Snapdrive services, everything worked fine again. Maybe this can help you to find the issue.


I just reinstalled the snapdrive and now it works just fine.





If you go into SnapDrive --> Server_name(Local) and in the Actions pane go to the "Transport Protocol Settings" you will see the options to add the filer to snapdrive. Make sure the username and password you have on the filer is also in here as well (as well as the correct protocol)