Data Backup and Recovery

Database Restore failed through SnapManager


Hi All

Objective was: Self system database restore

We have tried to resote one of our SAP system of its selft database through SMSAP Backup Restore method and it has failed to restore the database.

What we did in sequence:

1. Since SAP uses a standard layout for Oracle Database installations and in this layout, SAP places copies of the Oracle control files in the /oracle/<SID>/origlogA, /oracle/<SID>/origlogB, and /oracle/<SID>/sapdata1 file systems.

As per "SnapManager for SAP Best Practices" guid the control file in the sapdata1 file system conflicts with the SnapManager requirements for separating the control files and datafiles into separate volumes and must be adjusted to allow for fast restore capability.

Hence we had moved the control file from /oracle/<SID>/sapdata1 and placed it in a seperate volume group from datafiles to /oracle/<SID>/mirrlogA/cntrl/cntrl<SID>.dbf

2. Now took coupld of successfull backups: [Verified these backups by SnapManager itself]
> Full Offline Backup
> Full Online Backup with archive logs

3. In next step we manually deleted all control files from all three locations[as stated below], also deleted contents from sapdata1,2,3,4 folders and as well as from origlogA/B and mirrlogA/B.
   So that the retoration process will restore all files.

   /oracle/<SID>/origlogA/cntrl, /oracle/<SID>/origlogB/cntrl,  and /oracle/<SID>/mirrlogA/cntrl

4.Then invoked Backup Restore process from SnapManager and choosed the very first option "Complete Datafile/Tablespace Restore with Control Files" and it went got stuck at the
  phase of "Restore Priview" and throws below Errors. Finally restoration got failed. We had tried with both Offline and Online backups. But didn't succedded.

Error messages:

SMSAP-13032: Cannot perform operation: Backup Restore Preview. Root cause: SMSAP-07462: In order to preview a data file(s) restore, SnapManager must be able to mount the database.
Reason: ORACLE-20001: Error trying to change state to MOUNTED for database instance QE2:ORACLE-00001: Error executing SQL:[STARTUP MOUNT]. The command returned:

ORA-32004: obsolete or deprecated parameter(s) specified for RDBMS instance
ORA-00205:error in identifying control file, check alert log for more info

Could any of you please suggest what was wrong and how this can be resolved! Did we missed anything or any prerequisites need to be performed!

PFA the Error screen shots, which may help you to identify the root cause.