Data Backup and Recovery

Error with DBNEWID (""NID-00600") when cloning Oracle 9i database with SMO 3.0.1



we tried to clone an Oracle Datbase on NFS (AIX 5.3 and Oracle with SMO 3.0.1

all went well until SMO called the "NID" Oracle utility in order to change the SID database in the clone. At this step we got an error "NID-00600: Internal Error - [23] [0] [0] [0]"

it seems that the Oracle NID utility does not work on this server

we tried another Oracle 9i server and launch the nid tool outside SMO and we got the same error

has anyone got the same issue ? is there a workaround ?

we do not want to wait for a fix from Oracle if there is a valid workaround through SMO.

thanks for your help.



What is the specific version of 9i that you are running? I believe there are Oracle bugs that require you to have at least

We've seen a few different dbnewid-related failures that I can recall. Number of open cursors configured, and a file permissions issue come to mind.

I can look into this more when I am online but that is going to be much later in the day.

Given this particular error (NID-) is coming from Oracle, I would suggest going to Oracle Metalink to see if you can find that particular error. Same applies to a NetApp NOW search of our BURT tracking system and depending on your level of access.



This error (NID-00600) can also occur on "Oracle Server - Enterprise Edition - Version to", because of few data files in "offline dropped" state. Please refer to oracle metalink document ID: 292327.1 for more details.




hi Vrishali and MArk

thanks for your answer

we used the Oracle version of Oracle.

the customer opend a ticket at Oracle support.

But if you have already faced this issue or any useful information to solve this issue, i would apreciate.

we also tried to run the Oracle "nid" tool and in the nid.log file, it seemed that the tool was blocked on a particular data file (index file). We noticed then that this particular file has  a size different than the other files associated with the same tablespace. Maybe this file is corrupted but we could not prove that yet

thanks again.