Data Backup and Recovery

Even if you specify exclusion in XCP, it tries to return the atime

shirotan

If -preserve-atime is set even when the exclusion setting is specified, it seems that the file under ~ snapshot is also being tried, and an error is output to the console.
I want to avoid errors, but is there a way?
(I think it's best to take the source as a snapshot and not use preserve-atime.)

1 ACCEPTED SOLUTION

hmoubara

Hello,

 

The error you getting is normal, since the option -preserver-atime requires write permission to set timestamps on the source file, and since the file is a snapshot which is a read only file system.  So i believe you can ignore this warning message as xcp is trying to preserve atime at source which is snapshot, at target atime is preserved. So this is not an issue.

View solution in original post

7 REPLIES 7

hmoubara

Hello,

The -preserve-atime is to restore last accessed data on source before XCP read the file, can you provide what error are you receiving and what's the command you running trying to exclude the ~snapshot directory.

 

Thanks 

shirotan

Hell,

Below output messages.

 

XCP SMB 1.8; (c) 2022 NetApp, Inc.; Licensed toXXXXXXXXX until Sat Mar 26 17:13:12 2022

f 1.97MiB 252d2h smb02\bike.jpg
f 1.29KiB 42d21h smb02\Resource Athlete.lnk
f 2.21KiB 30d4h smb02\Google Chrome.lnk
f 8 7d6h smb02\test.txt
f 55.5KiB 92d1h smb02\opuser\teraterm-4.106\teraterm-4.106\cyglaunch.exe
f 31.7KiB 92d1h smb02\opuser\teraterm-4.106\teraterm-4.106\cygterm+.tar.gz

(omit messgaes)

error setting timestamps on "~snapshot\snap3\opuser\teraterm-4.106\teraterm-4.106\cygterm+-x86_64": errno (code: 5) Access dened。
error setting timestamps on "~snapshot\snap3\opuser\teraterm-4.106\teraterm-4.106": errno (code: 5) Access dened。
error setting timestamps on "~snapshot\snap3\opuser\teraterm-4.106": errno (code: 5) Access dened。
error setting timestamps on "~snapshot\snap3\opuser\teraterm-4.106\teraterm-4.106\lang": errno (code: 5) Access dened。
d 0 7d6h smb02\~snapshot
d 0 7d6h smb02

xcp scan -exclude path('*\~snapshot\*') -l -preserve-atime \\svm01\smb02
4,425 scanned, 3,317 excluded, 0 errors
Total Time : 50s
STATUS : PASSED
Sending statistics...

hmoubara

Hello,

 

The error you getting is normal, since the option -preserver-atime requires write permission to set timestamps on the source file, and since the file is a snapshot which is a read only file system.  So i believe you can ignore this warning message as xcp is trying to preserve atime at source which is snapshot, at target atime is preserved. So this is not an issue.

shirotan

Hello 

hmoubara

 

I understand that XCP cannot modify the atime in the snapshot area.
I have set "-exclude path ('* \ ~ snapshot \ *')", but I think the problem is that -preserve-atime targets it.

In the current XCP, atime modification of files in the excluded area works.
Is there no choice but to ignore any errors that occur?

hmoubara

Hello,

 

The error should just be ignore as this is not an issue. The -exclude is for the type of command being used with xcp like scan/verify/copy etc...

You can check the below KB:

https://kb.netapp.com/Advice_and_Troubleshooting/Data_Storage_Software/NetApp_XCP/XCP%3A_ERROR%3A_error_setting_timestamps_on_%22path_xxx%22%3A_errno_...

 

Thanks 

shirotan

Thank you for your replay.

OK I ignore this error messages.

shirotan

Thank you for your replay.

 

OK I ignore this error messages.

Public