Data Backup and Recovery

Exchange 2010 SP1 & SnapManager for Exchange 6.0


I have a new installation of Exchange 2010 SP1 w/ update rollup 2 and I am unable to manage the Exchange server with the SnapManager for Exchange application.  When adding server to be managed I get an error stating, "SnapManager initialization failed.", Failed to invoke Powershell Cmdlets.  I can however manage my other Exchange 2010 server in another location.

Anyone else seen this issue?



1) perhaps it's related to powershell basic settings

Try to switch the executionpolicy in Powershell von Restricted to unrestricted.

Open Powershell:

Set-ExecutionPolicy unrestricted

More information:

2) or it's just to run Snapmanager with "Run as Administrator" (W2k8 Server)

BR Stefan


Thanks for the suggestion, made the change and still not able to manage the server.


1) Snapmanager and Snapdrive User are member of local administrator group and Exchange Admin Group?

2) Do you have multiple mailbox server --> so you have to install on all mailbox server. (in this case at least Snapmanager User should be an active directory user)

BR Stefan

  1. Yes, this configuration has been in place for 2 years.  I am just adding Exchange 2010.  I can manage my other Exchange 2010 server from the SnapManger for Exchange console.
  2. Yes, multiple mailbox server's and SnapManger for Exchange works on all of them (2007 & 2010).

The SnapManager application works fine, I can run PowerShell commands from the server, I can use the Exchange PowerShell on the server without any issue's.  The server is up to date and no weird configurations have been made to it.  This is a clean install and not in production.  Whatever the SnapManger application is doing when it's trying to connect to my Exchange server is where it's failing, if I knew what cmdlets it was trying to run I might be able to fix it.

I do have an active case open as well, I was just searching for additional help from the community.

Thanks Again!


Issue has been corrected.

After the Exchange 2010 SP1 upgrade there was an issue with the Exchange Management Shell shortcut missing (  After I recreated that everything except SME was working.  After further investigation I found that some registry keys were missing (  I ended up copying the registry keys from a different Exchange 2010 server, everything is now working.

Thanks for all the help!


We are having the same issue but the powershell and bin folders are missing lots of files when compaired to a working Exchange server, so going to just reinstall Exchange.  Yes this is a new build.

Hope it helps


Re-install of Exchange fixed the issue.



In our case we had some of our servers in a test environment with flexclones. We dont had the DC form the parentdomain within the test environment, so we got that error. The application eventlog reported informational messages from the source "MSExchange ADAccess" which helped to get the right information. After booting the DC from the parentdomain the connection could be established and worked fine.


I'm also having this issue.  I don't think reinstalling Exchange is a legitimate solution (no offense).  I have a 4 server but having this issue with only one of the servers.  I also get this error in the Eventlogs:

Failed to verify Exchange info.

Error Code: 0xc0041491

Failed to invoke Exchange Powershell Cmdlets. Please check application event log for details, and make sure PowerShell, Exchange and Microsoft .NET framework are installed correctly.

I have snap manager